Bug 419081

Summary: doc license (OPL) is not using free clauses
Product: [Fedora] Fedora Reporter: Karsten Wade <kwade>
Component: php-manual-enAssignee: Tim Jackson <rpm>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-05 09:37:18 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 182235, 235706    

Description Karsten Wade 2007-12-10 20:31:48 EST
The package php-manual-en ships with documentation that is under the
Open Publication License (OPL) 1.0.  This license usage calls out two
optional clauses of the OPL that make the content not freely
modifiable or distributable.  Fedora uses the OPL *only* without the
optional clauses.

The file is:

file:///usr/share/doc/php-manual/en/html/copyright.html

Below are two texts.  (A) shows the license as how it currently appears in the
package.  (B) shows how it could appear.  We may also want to update the
copyright notice, although if the content hasn't changed at all since then,
perhaps not.

Since this is an upstream project you need to coordinate with, please
use me <kwade@redhat.com> if you need any help explaining the
situation to them.

(A)  
Copyright © 1997 - 2006 by the PHP Documentation Group. This material may be
distributed only subject to the terms and conditions set forth in the Open
Publication License, v1.0 or later. A copy of the Open Publication License is
distributed with this manual, the latest version is presently available at
http://www.opencontent.org/openpub/.

Distribution of substantively modified versions of this document is prohibited
without the explicit permission of the copyright holder.

Distribution of the work or derivative of the work in any standard (paper) book
form is prohibited unless prior permission is obtained from the copyright holder.

In case you are interested in redistribution or republishing of this document in
whole or in part, either modified or unmodified, and you have questions, please
contact the copyright holders at doc-license@lists.php.net. Note that this
address is mapped to a publicly archived mailing list.

The Chapter 46 section of the documentation is based on an initial
contribution by Zend Technologies. 

(B)

Copyright © 1997 - 2006 by the PHP Documentation Group. This material may be
distributed only subject to the terms and conditions set forth in the Open
Publication License, v1.0 or later. A copy of the Open Publication License is
distributed with this manual, the latest version is presently available at
http://www.opencontent.org/openpub/.

In case you are interested in redistribution or republishing of this document in
whole or in part, either modified or unmodified, and you have questions, please
contact the copyright holders at doc-license@lists.php.net. Note that this
address is mapped to a publicly archived mailing list.

The Chapter 46 section of the documentation is based on an initial contribution
by Zend Technologies.
Comment 1 Tim Jackson 2007-12-10 20:59:41 EST
Sent to doc-license@lists.php.net:
----------------------------------------------------------------------------
Hi

As a volunteer in the Fedora Project [1], a popular Linux distribution, I help
to package the PHP documentation. Since we, like most Linux distributions,
include the PHP language, it seems helpful to our users to include the
electronic reference manual too.

It has been brought to my attention [2] that the current PHP documentation
license prevents the distribution of modified copies of the work, which thus
makes it ineligible [3] for inclusion in Fedora, and most likely other
distributions which have policies about their content being exclusively Free
(the definition of which generally requires the right to modify and distribute
modified works).

Whilst I recognise that a licensing change may be regarded as significant on
your part, it seems to me to be a great shame to have to omit the PHP manual
from Free distributions due to the limiting clauses. I wonder therefore whether
there is any possibility that you would consider removing the restrictive
licensing clauses?

Thanks for your much-valued work on the PHP manual, and your time and
consideration of this licensing point.


Tim

[1] http://fedoraproject.org
[2] https://bugzilla.redhat.com/show_bug.cgi?id=419081
[3] http://fedoraproject.org/wiki/Licensing#SoftwareLicenses
Comment 2 Tom "spot" Callaway 2007-12-19 14:53:46 EST
I see that there is some discussion in that thread, but these docs will either
need to be relicensed (by upstream) or pulled before F9.
Comment 3 Tim Jackson 2008-01-05 09:24:52 EST
Thread on the doc-license list starts here:

http://news.php.net/php.doc.license/172

I can't see any hope of an immediate relicensing so I will pull for F9 alpha.
Comment 4 Tim Jackson 2008-01-05 09:37:18 EST
Retired from F9+ in CVS for now. If licensing changes I will put back in.
Comment 5 Tim Jackson 2008-09-24 18:12:58 EDT
Good news - the license upstream has changed to Creative Commons Attribution 3.0 license, which is OK according to the licensing guidelines. So I'll look at getting this back in again :-)