Bug 426948

Summary: slang apps don't show black properly...it's overly-bright somehow.
Product: [Fedora] Fedora Reporter: djb
Component: gnome-terminalAssignee: Behdad Esfahbod <behdad>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: mlichvar
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-03 14:47:29 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Xterm screen shot of slrn
none
gnome-terminal screenshot running slrn none

Description djb 2007-12-28 14:27:36 EST
Description of problem: it appears all slang apps have a problem displaying
black under X.  Black backgrounds and trim appears to be washed out and
overly-bright.  Didn't happen on previous RH releases.  slrn and ntsysv exhibit
the behavior, but it's more clear in something like slrn configured with white
text on a completely black background.   My terminals are also configured for
white on black and do not have this problem in terminal mode.  It only appears
to be apps based on slang.


Version-Release number of selected component (if applicable):
slang-2.1.2-2.fc8


How reproducible:
infinitely

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Lichvar 2008-01-02 10:55:05 EST
Slang doesn't use X so this is likely a terminal emulator problem. In which
terminal emulator is this happening? Has xterm the same problem?
Comment 2 djb 2008-01-02 11:27:27 EST
Dammit, good point.  Tried it in an xterm and it did not exhibit the behavior. 
Must be a problem with gnome-terminal and slang apps.
Comment 3 Behdad Esfahbod 2008-01-02 18:45:20 EST
Can you run under script(1) and attach output here?
Comment 4 djb 2008-01-02 22:55:17 EST
I'm not sure what you hope that will accomplish.  The problem is that
gnome-terminal, if set to have a background color of black, doesn't display
slang apps properly.  Any solid black is an extra bright area that's hard to
see.  Running the same app in xterm works fine.

I don't know of a good example other than something like slrn.  ntsysv is mostly
blue with a black border that you *can* see it in, but it's not as obvious since
the black area isn't large.  

slrn seems to do something hokey and 'script -c slrn slrn.out' just gives me
some non-slang stdout anyway.

I'm sure you can replicate this by setting up slrn.  Attached is the set of
colors I use in my .slrnrc (just replace whatever it creates by default with
this and run it again).  Try in both a gnome-terminal and in an xterm and you
should see what I mean.  Make sure and set the background in both the
gnome-terminal and the xterm to black *first*, though.

(Tried to 'create attachment' instead of pasting, but I got a Server Busy
message of some kind.)

%---------------------------------------------------------------------------
% Colors
%---------------------------------------------------------------------------
%color header_number "red" "white"
%color header_name "red" "white"
%color normal black white
%color error red white
%color status yellow blue
%color group blue white
%color article blue white
%color cursor brightgreen white
%color author magenta white
%color subject black white
%color headers brightcyan white
%color menu yellow blue
%color menu_press blue yellow
%color tree red white
%color quotes red white
%color thread_number blue white
%color high_score red white
%color signature red white
%color description blue white
%color tilde red white

color header_number green black
color normal white black
color error red black
color status yellow blue
color group yellow black
color article yellow black
color cursor brightgreen black
color author yellow black
color subject white black
color headers brightcyan black
color menu yellow blue
color menu_press blue yellow
color tree green black
color quotes white black
color thread_number yellow black
color high_score yellow black
color signature white black
color description green black
color tilde green black
color header_name green black

%-----------------------------------------------------
% Monochrome attributes for monochrom terminals
%-----------------------------------------------------
mono normal             none
mono header_number      none
mono error              blink bold
mono status             reverse
mono group              bold
mono article            none
mono cursor             bold reverse
mono author             none
mono subject            none
mono headers            bold
mono menu               reverse
mono menu_press         none
mono tree               bold
mono quotes             underline
mono thread_number      bold
mono high_score         bold
mono signature          none
mono description        none
Comment 5 Behdad Esfahbod 2008-01-03 11:54:41 EST
Can you attach a screenshot of xterm and g-t then?
Comment 6 djb 2008-01-03 14:08:22 EST
Created attachment 290763 [details]
Xterm screen shot of slrn
Comment 7 djb 2008-01-03 14:08:55 EST
Created attachment 290764 [details]
gnome-terminal screenshot running slrn
Comment 8 Behdad Esfahbod 2008-01-03 14:23:47 EST
Ah, I see what you mean.  This is the new default Tango color scheme.  Can you
confirm that changing the color scheme to something classic fixes it?

I'm not a huge fan of the washed out colors, but sometimes I appreciate the lack
of crispiness in the colors.
Comment 9 djb 2008-01-03 14:41:41 EST
Ah, I see.  Yeah, changed it to xterm and it fixed it.  I didn't think it was
something like that because I normally just set my background color to black in
the terminal and it's never just changed like that on me by running an app.  I
guess I see the point, but it's unusable to me in *that* configuration.  I'd
have to change the app settings at least some to make that work, but I'm happier
with it back to normal.

Okay, close bug.  Thanks. 
Comment 10 Behdad Esfahbod 2008-01-03 14:47:29 EST
I've seen the overly-bright issue with some monitors.  But on my current screen
for example it looks very good.  As I said, I'm not a huge fan, but changing the
defaults again can just add more harm at this point.