Bug 427339

Summary: [HTS5.1-18][harness][ia64][EL4] - hts plan giving traceback error
Product: Red Hat Hardware Certification Program Reporter: Satyabrata Maitra <smaitra>
Component: Test Suite (harness)Assignee: Greg Nichols <gnichols>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5CC: llim
Target Milestone: ---   
Target Release: ---   
Hardware: ia64   
OS: Linux   
Whiteboard:
Fixed In Version: RHBA-2008-0495 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-23 19:53:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
hts traceback error file none

Description Satyabrata Maitra 2008-01-03 09:16:50 UTC
Description of problem:
When attempted to test hts-5.1-18 on ia64 system, with RHEL4.6-AS, the command,
hts plan --server <ip of test server>, its given traceback error.

In Past, there was a bug filed almost looks like the same (referenced below),
but, that time, it was found that the system under test was not installed with
dbus packages. As soon as those were installed, the bug fixed.
But this time all the dbus packages are already installed in the system, still
the bug persists.
Previous Bug Reference :- https://bugzilla.redhat.com/show_bug.cgi?id=307081

Dbus packages installed in the system are :-
dbus-x11-0.22-12.EL.9
dbus-devel-0.22-12.EL.9
dbus-glib-0.22-12.EL.9
dbus-python-0.22-12.EL.9
dbus-0.22-12.EL.9

Version-Release number of selected component (if applicable):
hts-5.1-18
O.S. - RHEL4-U6-AS

How reproducible:
Not always, because, the same when I installed in EL4.6 ia64 QE stable systems,
and there it was installed properly without any error, but in another ia64
system, I faced this problem.

Steps to Reproduce:
1. Install hts and dependent packages - dt, stress, lmbench in EL4.6-AS system
2. Execute the command hts plan --server <ip of the test server>
3. Observe the traceback
  
Actual results:
hts tool not creating the test plans. Giving traceback.

Expected results:
It should create the test plans for that specific system.

Additional info: Traceback error file is attached with this bug.

Comment 1 Satyabrata Maitra 2008-01-03 09:16:50 UTC
Created attachment 290720 [details]
hts traceback error file

Comment 2 Greg Nichols 2008-01-04 14:03:03 UTC
Is the RHEL 4 U6 install running as a fully-virtualized or para-virtualized guest?

Also, please check that the dbus-deamon is running.

Thanks!

Comment 3 Greg Nichols 2008-01-09 18:45:55 UTC
specifically, start haldaemon and messagebus and see if hts plan will run.

Comment 4 Satyabrata Maitra 2008-01-10 06:50:37 UTC
After starting haldaemon and messagebus, this problem is fixed.
Thanks Greg!

Comment 5 Greg Nichols 2008-03-18 16:24:53 UTC
Fixed in HTS 5.2 R5: added test and error message to check if HAL daemons are
running.

Comment 9 errata-xmlrpc 2008-06-23 19:53:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0495.html