Bug 4276

Summary: impossible to specify hostname with kickstart install
Product: [Retired] Red Hat Linux Reporter: scottm
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-11 15:16:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description scottm 1999-07-30 16:42:59 UTC
It appears that there is no way to specify the hostname of a
machine when doing a kickstart install.  Documentation
reccomends getting network information from a bootp server,
but I shouldn't have to install and configure a bootp server
just to do a machine installation.

Kickstart config file includes a networking line like

network --bootproto static --ip 192.168.0.2 --netmask
255.255.255.0 --gateway 192.168.0.1 --nameserver 192.168.0.1

but does not recognize any sort of hostname option.  The
installer immediately kicks out for user input to get the
hostname after it "fails to determine" the hostname
information.

Easy resolution for this bug?  Allow an option in the
network line of ks.cfg to read --hostname "machine.domain".
This would allow a completely automated kickstart install on
a private network without running a bootp server.  I can't
seen any reason _not_ to include the option, since all that
happens is the user has to enter the info anyways and he's
already input the IP and network info into ks.cfg ...

Thanks!

Comment 1 Jay Turner 2000-02-11 15:15:59 UTC
Issue is resolved in the latest version of the installer.