Bug 428537

Summary: Pulseaudio no longer supports M-Audio Audiophile 24/96
Product: [Fedora] Fedora Reporter: Dennis Jacobfeuerborn <dennisml>
Component: pulseaudioAssignee: Lennart Poettering <lpoetter>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: darrellpf, jfrieben, lkundrak, lpoetter, michel, pierre-bugzilla, rpm
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-18 09:00:34 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705    

Description Dennis Jacobfeuerborn 2008-01-12 19:38:46 EST
Audio stops working for me if I start using *either* PA 0.9.8 or a current
rawhide kernel. Going back to 0.9.7 and the latest F8 kernel fixes the problem.
I've upgraded to rawhide almost completely except for the X server, GDM and some
pulseaudio packages. 

This is the card I'm using:
01:08.0 Multimedia audio controller: VIA Technologies Inc. ICE1712 [Envy24] PCI
Multi-Channel I/O Controller (rev 02)
	Subsystem: VIA Technologies Inc. M-Audio Delta Audiophile

Here are the package definitions combinations I have tried:

f8 kernel = kernel-2.6.23.9-85.fc8
f8 pulseaudio = 
    pulseaudio-0.9.7-0.17.svn20071017.fc8
    pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
    pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
    pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
    pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
    (all other pulseaudio-* packages are updated to the rawhide versions)

rawhide kernel = kernel-2.6.24-0.147.rc7.git2.fc9
rawhide pulseaudio =
    pulseaudio.i386                          0.9.8-4.fc9
    pulseaudio-core-libs.i386                0.9.8-4.fc9
    pulseaudio-esound-compat.i386            0.9.8-4.fc9
    pulseaudio-module-gconf.i386             0.9.8-4.fc9
    pulseaudio-module-x11.i386               0.9.8-4.fc9

These packages lead to the following results:
f8 kernel + f8 pulseaudio = WORKS
f8 kernel + rawhide pulseaudio = FAILS
rawhide kernel + f8 pulseaudio = FAILS
rawhide kernel + rawhide pulseaudio = FAILS

Here is the syslog output for the rawhide kernel + rawhide pulseaudio combination:

Jan 13 00:34:12 nexus pulseaudio[3070]: main.c: setrlimit(RLIMIT_NICE, (31, 31))
failed: Operation not permitted
Jan 13 00:34:12 nexus pulseaudio[3070]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9))
failed: Operation not permitted
Jan 13 00:34:12 nexus pulseaudio[3070]: alsa-util.c: Device hw:0 doesn't support
2 channels, changed to 10.
Jan 13 00:34:12 nexus pulseaudio[3070]: alsa-util.c: Device hw:0 doesn't support
sample format s16le, changed to s32le.
Jan 13 00:34:12 nexus pulseaudio[3070]: alsa-util.c: Cannot find fallback mixer
control "PCM".
Jan 13 00:34:12 nexus pulseaudio[3070]: module-alsa-sink.c: Failed to create
sink object
Jan 13 00:34:12 nexus pulseaudio[3070]: module.c: Failed to load  module
"module-alsa-sink" (argument: "device_id=0
sink_name=alsa_output.pci_1412_1712_alsa_playback_0"): initialization failed.
Jan 13 00:34:12 nexus pulseaudio[3070]: alsa-util.c: Device hw:0 doesn't support
2 channels, changed to 12.
Jan 13 00:34:12 nexus pulseaudio[3070]: alsa-util.c: Device hw:0 doesn't support
sample format s16le, changed to s32le.
Jan 13 00:34:12 nexus pulseaudio[3070]: alsa-util.c: Cannot find fallback mixer
control "Mic".
Jan 13 00:34:12 nexus pulseaudio[3070]: module-alsa-source.c: Failed to create
source object
Jan 13 00:34:12 nexus pulseaudio[3070]: module.c: Failed to load  module
"module-alsa-source" (argument: "device_id=0
source_name=alsa_input.pci_1412_1712_alsa_capture_0"): initialization failed.

and the output of "pulseaudio -vv" for that combination:

[root@nexus ~]# pulseaudio -vv
I: core-util.c: Successfully gained nice level -11.
W: main.c: This program is not intended to be run as root (unless --system is
specified).
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=1
sink_name=alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:1...
I: module-alsa-sink.c: Successfully opened device front:1.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:1
I: alsa-util.c: Unable to attach to mixer front:1: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:1'
I: alsa-util.c: Cannot find mixer control "Master".
I: alsa-util.c: Using mixer control "PCM".
I: sink.c: Created sink 0
"alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0" with sample spec "s16le
2ch 44100Hz"
I: source.c: Created source 0
"alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0.monitor" with sample spec
"s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware
volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=1
sink_name=alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=1
source_name=alsa_input.pci_10de_3f0_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:1...
I: module-alsa-source.c: Successfully opened device front:1.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:1
I: alsa-util.c: Unable to attach to mixer front:1: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:1'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1
"alsa_input.pci_10de_3f0_sound_card_0_alsa_capture_0" with sample spec "s16le
2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware
volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=1
source_name=alsa_input.pci_10de_3f0_sound_card_0_alsa_capture_0").
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_sound_card_0_alsa_hw_specific_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_10de_3f0_sound_card_0_alsa_control__1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0
sink_name=alsa_output.pci_1412_1712_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:0...
I: alsa-util.c: PCM device front:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround40:0...
I: alsa-util.c: PCM device surround40:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround41:0...
I: alsa-util.c: PCM device surround41:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround50:0...
I: alsa-util.c: PCM device surround50:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround51:0...
I: alsa-util.c: PCM device surround51:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround71:0...
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
'cards.ICE1712.pcm.surround71.0:CARD=0'
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned
error: No such file or directory
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: No such file or directory
D: alsa-util.c: Trying hw:0 as last resort...
W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 10.
W: alsa-util.c: Device hw:0 doesn't support sample format s16le, changed to s32le.
I: module-alsa-sink.c: Successfully opened device hw:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Master".
W: alsa-util.c: Cannot find fallback mixer control "PCM".
D: sink.c: pa_sink_new: Assertion <map && pa_channel_map_valid(map)> failed.
E: module-alsa-sink.c: Failed to create sink object
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0
sink_name=alsa_output.pci_1412_1712_sound_card_0_alsa_playback_0"):
initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_sound_card_0_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0
source_name=alsa_input.pci_1412_1712_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: alsa-util.c: PCM device front:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround40:0...
I: alsa-util.c: PCM device surround40:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround41:0...
I: alsa-util.c: PCM device surround41:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround50:0...
I: alsa-util.c: PCM device surround50:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround51:0...
I: alsa-util.c: PCM device surround51:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround71:0...
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
'cards.ICE1712.pcm.surround71.0:CARD=0'
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned
error: No such file or directory
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: No such file or directory
D: alsa-util.c: Trying hw:0 as last resort...
W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 12.
W: alsa-util.c: Device hw:0 doesn't support sample format s16le, changed to s32le.
I: module-alsa-source.c: Successfully opened device hw:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Capture".
W: alsa-util.c: Cannot find fallback mixer control "Mic".
D: source.c: pa_source_new: Assertion <map && pa_channel_map_valid(map)> failed.
E: module-alsa-source.c: Failed to create source object
E: module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0
source_name=alsa_input.pci_1412_1712_sound_card_0_alsa_capture_0"):
initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_sound_card_0_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_sound_card_0_alsa_midi_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_1412_1712_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink
alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Source
alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source
alsa_input.pci_10de_3f0_sound_card_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #9; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules//module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Sink
alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0 idle for too long,
suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Source
alsa_input.pci_10de_3f0_sound_card_0_alsa_capture_0 idle for too long,
suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source
alsa_output.pci_10de_3f0_sound_card_0_alsa_playback_0.monitor idle for too long,
suspending ...
Comment 1 Lennart Poettering 2008-01-12 20:00:32 EST
audio device #1 works fine when opened as front:1

audio device #0 is problematic however. This looks like some ALSA issue. None of
the normal ALSA devices like "front:0" seem to work. And if we open it as hw:0
ALSA insists in 12 channels, which PA cannot really make any sense of in terms
of a channel map. i.e. the greatest thing we know is 8 channel audio where
channels are positioned in a 7.1 pattern. 12 channels is just not known, and I
have never seen anything like this before.

There's something wrong with your ALSA. Try if upgrading ALSA fixes your problems.

This should probably be reassigned to ALSA in some way.
Comment 2 Dennis Jacobfeuerborn 2008-01-12 23:21:44 EST
ALSA is the latest version in rawhide (1.0.15). What has changed in pulseaudio
to expose this bug in ALSA? After all things work fine with 0.9.7.
Comment 3 darrell pfeifer 2008-01-17 00:07:39 EST
This is a "me too"

Pulseaudio sound stopped working for me about a week ago. I run daily rawhide
updates (eeeks, living on the edge).

Gnome System/Admin/SoundCard detection shows Intel ICH6 with snd-intel8x0.
Playing a test sound works.

However, the sound control panel can't find any devices. padevchooser shows no
default source or sink. pavucontrol just dies. 
Comment 4 darrell pfeifer 2008-01-18 23:06:50 EST
Plugging in a USB camera/mic that used to work (but doesn't now) I get

Jan 18 19:56:20 localhost kernel: usb 5-1: new full speed USB device using
uhci_hcd and address 2
Jan 18 19:56:20 localhost kernel: usb 5-1: configuration #1 chosen from 1 choice
Jan 18 19:56:22 localhost pulseaudio[2562]: alsa-util.c: Error opening PCM
device hw:7: No such device
Jan 18 19:56:22 localhost pulseaudio[2562]: module.c: Failed to load  module
"module-alsa-source" (argument: "device_id=7
source_name=alsa_input.usb_device_46d_8a9_noserial_if1_sound_card_0_alsa_capture_0"):
initialization failed.
Comment 5 Geoff Childs 2008-01-26 04:44:55 EST
Another "me too" I'm afraid. I've got the same sound card as #1 but using a
x86_64 build and have the exact same problem. Managed to get something working
by changing the default.pa file by commenting out:
load-module module-hal-detect

and uncommenting:
load-module module-alsa-sink
load-module module-alsa-source device=hw:1,0

This seemed to work but then broke again later so not sure if it was just a
fluke so rolled back to 0.9.7 and it all works again.
Comment 6 Michel Alexandre Salim 2008-01-27 13:22:58 EST
Looks like a kernel bug, not a pulseaudio bug: as with Darrell, my webcam (on a
Thinkpad, using linux-uvc) also stopped working with the Rawhide kernel. Sound
(Intel HDA) is also not working.
Comment 7 Michel Alexandre Salim 2008-01-27 20:22:55 EST
Please disregard my comment -- turns out it's an SELinux bug (discussed on
fedora-selinux-list already)
Comment 8 darrell pfeifer 2008-01-27 20:32:46 EST
A couple of corrections related to the last couple of bug entries.

First, I can do sound card detection via the gnome control panel and do hear
sound via my Intel ICH device. I don't know how that mechanism differs from
alsa/pulseaudio, but it works.

Second, I have selinux turned off, so it isn't selinux related.
Comment 9 Dennis Jacobfeuerborn 2008-01-29 22:57:53 EST
I'm now running kernel-2.6.24-2 and self-made 1.0.16rc1 alsa rpms and I still
get the same error with pulseaudio.

Disabling pulseaudio and using alsa directly works fine.
Comment 10 Lubomir Kundrak 2008-02-05 15:19:44 EST
Attempting to reassign to kernel, and see if they can be helpful if this is
really ALSA issue. Maybe it would make sense to report this to (ALSA) upstream?
Comment 11 Dennis Jacobfeuerborn 2008-02-06 09:00:07 EST
(In reply to comment #10)
> Maybe it would make sense to report this to (ALSA) upstream?

That's why I was asking about the differences about PA 0.9.7 and 0.9.8 above.
0.9.7 worked fine after all so whatever changed there is either causing the
problem or revealing it in ALSA. Knowing that would help to file a useful bug
report upstream.
Comment 12 Lubomir Kundrak 2008-02-06 09:36:31 EST
Dennis: According to release notes: "Rework ALSA surround sound configuration
completely" [1]. Sound to me like it would not be easily possible to identify a
single change that would be responsible for that.

[1] http://pulseaudio.org/milestone/0.9.8
Comment 13 Dennis Jacobfeuerborn 2008-02-06 10:56:10 EST
Maybe not, but it should at least be possible to identify the failing ALSA
function call, its parameters and the exact error code it returns so that a
minimal testcase can be created and filed upstream.
Comment 14 Lubomir Kundrak 2008-02-06 11:05:28 EST
Agreed. I tought that comment #1 could be sufficient, but probably Lennart can
be even more helpful here. Adding him to Cc list.
Comment 15 darrell pfeifer 2008-03-13 19:35:05 EDT
My sound still doesn't work. There has been some discussion on the fedora-devel
list, so I'm adding my pulseaudio -vv output here.

As per the discussion on the list, I ensured there was no mention of sound
devices in modules.conf

I: main.c: PolicyKit refuses acquire-high-priority privilige.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested
in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us
priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate
PolicyKit priviliges, or become a member of 'pulse-rt', or increase the
RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: High-priority scheduling enabled in configuration but now allowed by
policy. Disabling forcibly.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_playback_4
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_3
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0
sink_name=alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM front:0
I: alsa-util.c: Couldn't open PCM device front:0: Invalid argument
D: alsa-util.c: Trying surround40:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround40:0
I: alsa-util.c: Couldn't open PCM device surround40:0: Invalid argument
D: alsa-util.c: Trying surround41:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround41:0
I: alsa-util.c: Couldn't open PCM device surround41:0: Invalid argument
D: alsa-util.c: Trying surround50:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround50:0
I: alsa-util.c: Couldn't open PCM device surround50:0: Invalid argument
D: alsa-util.c: Trying surround51:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround51:0
I: alsa-util.c: Couldn't open PCM device surround51:0: Invalid argument
D: alsa-util.c: Trying surround71:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: Invalid argument
D: alsa-util.c: Trying hw:0 as last resort...
ALSA lib pcm_hw.c:1240:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such file or directory
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0
sink_name=alsa_output.pci_8086_266e_sound_card_0_alsa_playback_0"):
initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_playback_0
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0
source_name=alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM front:0
I: alsa-util.c: Couldn't open PCM device front:0: Invalid argument
D: alsa-util.c: Trying surround40:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround40:0
I: alsa-util.c: Couldn't open PCM device surround40:0: Invalid argument
D: alsa-util.c: Trying surround41:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround41:0
I: alsa-util.c: Couldn't open PCM device surround41:0: Invalid argument
D: alsa-util.c: Trying surround50:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround50:0
I: alsa-util.c: Couldn't open PCM device surround50:0: Invalid argument
D: alsa-util.c: Trying surround51:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround51:0
I: alsa-util.c: Couldn't open PCM device surround51:0: Invalid argument
D: alsa-util.c: Trying surround71:0...
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: Invalid argument
D: alsa-util.c: Trying hw:0 as last resort...
ALSA lib pcm_hw.c:1240:(_snd_pcm_hw_open) Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such file or directory
E: module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0
source_name=alsa_input.pci_8086_266e_sound_card_0_alsa_capture_0"):
initialization failed.
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_capture_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_266e_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
D: module-default-device-restore.c: No previous default sink setting, ignoring.
D: module-default-device-restore.c: No previous default source setting, ignoring.
I: module.c: Loaded "module-default-device-restore" (index: #4; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #7; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib/pulse-0.9/modules/module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #8; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired


Comment 16 Dennis Jacobfeuerborn 2008-03-14 20:05:05 EDT
FWIW I did some debugging to try to figure out why "front:0" can't be opened.

The offending code is the following in alsa-util.c:

    if (require_exact_channel_number) {
        if ((ret = snd_pcm_hw_params_set_channels(pcm_handle, hwparams, c)) < 0)
            goto finish;
    } else {
        if ((ret = snd_pcm_hw_params_set_channels_near(pcm_handle, hwparams,
&c)) < 0)
            goto finish;
    }

In the case of "front:0" the function snd_pcm_hw_params_set_channels() get
called with a value of "2" for the parameter c. This results in the error
"Invalid argument" by ALSA.
Comment 17 Dennis Jacobfeuerborn 2008-03-14 20:29:05 EDT
Also filed an ALSA bug here:
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=3846
Comment 18 darrell pfeifer 2008-03-21 14:44:33 EDT
Sound started working for me today with the post-freeze rawhide update

pulseaudio-0.9.8-12.fc9.i386

None of the various volume controls (pulse, applet, etc) are working for me, but
sound is definitely back.
Comment 19 Dennis Jacobfeuerborn 2008-03-21 21:21:25 EDT
Nothing has changed. Pulseaudio still cannot access the mixer.
Comment 20 Lubomir Kundrak 2008-03-31 09:55:52 EDT
By the way 0.9.10 is out; also in rawhide -- please look if it's any better.
Comment 21 Dennis Jacobfeuerborn 2008-03-31 14:56:44 EDT
Upgrading to 0.9.10 did not fix the problem.
Comment 22 Dennis Jacobfeuerborn 2008-04-23 08:44:49 EDT
There is progress on this in the upstream bug. Apparently the problem is that PA
opens the device "front" which doesn't work but "plug:front" does. 

speaker-test -Dfront -c 2 -t wav
=> "invalid argument"

speaker-test -Dplug:front -c 2 -t wav
=> correct sound output

The question is how to tell PA to use the correct device or how to change the
alsa settings that opening "front" does the RightThing(tm)?
Comment 23 Lennart Poettering 2008-04-23 18:18:29 EDT
Its an issue with ALSA. It lacks any definition of a channel mapping for sound
cards with > 8 channels. surround71: is the maximum supported.

If PA has no idea about the channel mapping of a device it cannot make use of it.

A possible fix is to pass the channel mapping manually via the channel_map
argument to module-alsa-sink. However, much better would be if ALSA would learn
what to do with 10 and 12ch sound cards and assign a sensible channel mapping so
that we can auto detect it. Something like surround91: or surround111 is needed.

In short: ALSA doesn't do > 8 channel audio without passing it manual
information. PA just uses what ALSA provides. 

It's a limitation of ALSA, not so much of PA.

This should be reported upstream of ALSA.
Comment 24 Dennis Jacobfeuerborn 2008-04-23 21:45:32 EDT
I guess the question I have is why does this card work flawlessly with any other
application but PA? I disabled PA and audacious, mplayer, the firefox flash
plugin, xine, etc. work out of the box with ALSA but using ALSA directly means I
have to live without the nice features PA provides such as app-specific volume
control.

The PA version in Fedora 8 didn't have problems with this card either. Why can't
the current version not fall back to the old behavior when it detects an
unsupported channel configuration?

I don't really care about the > 8 channels, plain and simple stereo would be
just fine and certainly better than having no audio output at all.
Comment 25 Dennis Jacobfeuerborn 2008-04-24 21:04:08 EDT
Adding "load-module module-alsa-sink device=plug:front channels=2
channel_map=front-left,front-right" in /etc/pulse/default.pa seems to work for me.
Comment 26 Bug Zapper 2008-05-14 00:45:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 27 Tim Jackson 2008-10-26 05:57:24 EDT
Lennart, I think I understand what you're saying but Dennis's point in comment #24 is still puzzling: why/how do apps other than PA seem to "do something sensible" notwithstanding ALSA's limitations re channel mapping? Can PA not be made to fall back to whatever behaviour they are using?
Comment 28 Dennis Jacobfeuerborn 2008-10-26 15:21:23 EDT
The latest PA version in rawhide no longer has this problem and now seems to do the right thing. It now seems to work out of the box except for a skipping problem every minute or so but I that's a different issue which I'm planning to file a bug about separately.
Comment 29 Lennart Poettering 2008-12-18 09:00:34 EST
PA in F10 synthesizes a channel mapping if necessary and should thus support this soundcard just fine again.