Bug 429518

Summary: deplist shows unsatisfied dependency
Product: Red Hat Enterprise Linux 5 Reporter: Jan Hutař <jhutar>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED NOTABUG QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.1   
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-06 09:11:07 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jan Hutař 2008-01-21 04:54:52 EST
Description of problem:
While dependency is already installed, yum lists it as a unsatisfied.

# yum deplist test-regular
Finding dependencies: 
Setting up repositories
regular022                100% |=========================| 1.1 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================|  762 B    00:00     
################################################## 1/1
package: test-regular.i386 0.2-2
  dependency: /bin/sh
   Unsatisfied dependency
# rpm -q --whatprovides /bin/sh
bash-3.1-16.1.i386


Version-Release number of selected component (if applicable):
yum-3.0.1-5.el5.noarch


How reproducible:
always


Steps to Reproduce:
1. yum deplist test-regular


Actual results:
Unsatisfied dependency


Expected results:
Satisfied dependency


Additional info:
Please note that test-regular is my simple test package and regular022 is my 
test repository. I do not have other repositories enabled:

# ls regular-0.2-2/
comps.xml  repodata  test-regular-0.2-2.i386.rpm
# rpm -qp --requires regular-0.2-2/test-regular-0.2-2.i386.rpm 
/bin/sh  
/bin/sh  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Seems to me yum check only content of the repository if that requirement is 
available. It does not check already installed packages. But this is maybe a 
feature, not a bug?
Comment 1 James Antill 2008-01-21 10:01:42 EST
 Can you re-test with the 3.2.8 version that should be going out in 5.2?
Comment 2 Jan Hutař 2008-02-06 05:11:41 EST
Hello,
it is still there:

# rpm -q yum
yum-3.2.8-6.el5.noarch
# yum clean all
Cleaning up Everything
# yum deplist test
repo011                   100% |=========================| 1.1 kB    00:00     
primary.xml.gz            100% |=========================| 1.1 kB    00:00     
repo011   : ################################################## 7/7
repo022                   100% |=========================| 1.1 kB    00:00     
primary.xml.gz            100% |=========================| 1.0 kB    00:00     
repo022   : ################################################## 5/5
Finding dependencies: 
package: test.i386 0.2-2
  dependency: /bin/sh
   Unsatisfied dependency
package: test.i386 0.1-1
  dependency: /bin/sh
   Unsatisfied dependency
# rpm -q --whatprovides /bin/sh
bash-3.1-16.1.i386
Comment 3 James Antill 2008-02-06 09:11:07 EST
 Sorry, I hadn't realized before what you were doing:

"""Seems to me yum check only content of the repository if that requirement is 
available. It does not check already installed packages. But this is maybe a 
feature, not a bug?"""

...this is true, deplist just works off of the data in the repos. The most
obvious "feature" here is if you take a package from "yum list extras" and do a
deplist on it, no data will be shown. The next one being that if the deps for
the package isn't in a repo, it can't satisfy them.
Comment 4 Jan Hutař 2008-02-06 09:21:07 EST
I see, thanks for explanation.