Bug 429689

Summary: cp: cannot stat 'chroot': No such file or directory
Product: [Fedora] Fedora Reporter: Valent Turkovic <valent.turkovic>
Component: revisorAssignee: Jeroen van Meeuwen <vanmeeuwen+fedora>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: jonathansteffan, madko, maurizio.antillon, pheuer, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-16 23:41:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Valent Turkovic 2008-01-22 13:38:43 UTC
Description of problem:
revisor gives lots of these messages:

cp: cannot stat 'chroot': No such file or directory

if I do in console:

# stat chroot
stat: cannot stat `chroot': No such file or directory

I get the same error, but if I do with full path then I don't get this error:

# stat /usr/sbin/chroot
  File: `/usr/sbin/chroot'
  Size: 18828           Blocks: 48         IO Block: 4096   regular file
Device: 806h/2054d      Inode: 84503       Links: 1
Access: (0755/-rwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2008-01-21 15:10:18.000000000 +0100
Modify: 2007-12-05 14:24:59.000000000 +0100
Change: 2007-12-09 13:48:13.000000000 +0100




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jeroen van Meeuwen 2008-01-24 11:51:19 UTC
Please verify if the package "coreutils" is in the package set.

Comment 2 Valent Turkovic 2008-01-24 12:09:03 UTC
off course it is

# yum install coreutils
Package coreutils - 6.9-12.fc8.i386 is already installed.


Comment 3 Philip Heuer 2008-02-04 02:25:27 UTC
I also encounter this issue during the "Build isolinux and Installer" step. I
tried creating symbolic links to chroot in both /bin and /usr/bin. This did not
resolve the "cp: cannot stat `chroot': No such file or directory" message. I am
using coreutils-6.9-12.fc8 and revisor-2.0.5-15.fc8. Running "rpm -ql coreutils
| grep chroot" confirms that coreutils installs chroot to /usr/sbin/chroot. The
coreutils package was also included in the distribution package set.

Comment 4 Philip Heuer 2008-02-04 03:19:41 UTC
After finding the --debug flag in /usr/sbin/revisor, I found that the errors are
occurring during the following the buildinstall stage of "Build isolinux and
Installer". The pertinent debug output was:

Initting progress bar for Building Installation Images
Setting rundir to /var/tmp/revisor-rundir
Running command: /usr/lib/anaconda-runtime/buildinstall --product Fedora
--variant f8-i386-custom-local --version 8 --release "Fedora 8" --prodpath
Packages /var/tmp/revisor-pungi/8/f8-i386-custom-local/i386/os
Extra information: /var/tmp/revisor-rundir False None

Comment 5 Philip Heuer 2008-02-04 05:04:26 UTC
After more tracing, the problem seems to lie in
/usr/lib/anaconda-runtime/upd-instroot script (called from buildinstall) which
is in the anaconda-runtime package. I have filed Bug 431392 against the anaconda
package since there is not a separate anaconda-runtime package in the bugzilla
database.

Comment 6 Jeroen van Meeuwen 2008-02-04 10:55:32 UTC
Reopened that bug after it was closed "RAWHIDE" with the indication that they'll
need to be more specific about what is causing this.

Comment 7 Jeroen van Meeuwen 2008-10-16 23:41:29 UTC
Closing this bug