Bug 430624

Summary: pulseaudio should not be dependent on GConf preference
Product: [Fedora] Fedora Reporter: David Baron <dbaron>
Component: gnome-sessionAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 8CC: bnocera, pierre-bugzilla
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.22.2.1-2.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-30 20:12:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Baron 2008-01-29 05:39:30 UTC
Description of problem:  Since I upgraded to Fedora 8, most programs are unable
to play sound unless I manually start pulseaudio.  Something as basic as
functioning sound should work without starting something at the command line.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.8-5.fc8
gnome-session-2.20.2-1.fc8
xorg-x11-xinit-1.0.7-2.fc8
(not really sure what's applicable here)

How reproducible: Always.

Steps to Reproduce:
1. log in to GNOME
2. $ aplay /usr/share/sounds/error.wav
3. $ pulseaudio &
4. $ aplay /usr/share/sounds/error.wav

Actual results:

After (2), no sound is produced, and I get the message:
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:546: audio open error: Connection refused

After (4), sound works, and aplay prints:
Playing WAVE '/usr/share/sounds/error.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Mono

Expected results:  Sound works after step (2).

Comment 1 David Baron 2008-01-29 21:45:19 UTC
Going into gconf-editor and changing desktop -> gnome -> sound -> enable_esd to
true seems to have fixed this (and I think also the warnings in bug 428056,
assuming that the pulseaudio output shows up in my .xsession-errors which it
looks like it does).  But it seems like that should have been selected by
default (or not using a pref that did something else in older gnome versions?).

Comment 2 Lubomir Kundrak 2008-02-28 18:14:14 UTC
This should work this way and is the default.
More on this:
http://dailypackage.fedorabook.com/index.php?/archives/172-Wednesday-Why-How-does-Pulseaudio-start.html

Comment 3 Colin Walters 2008-05-14 01:42:26 UTC
This is a GNOME bug.  There shouldn't be a preference for "make my sound work".

I think the issue here is that David had an entry in GConf to turn ESD off which
was carried over from an earlier install.  

Reopening this, and will reassign to gnome-session.

Comment 4 Colin Walters 2008-05-14 21:39:23 UTC
Patch is pending upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=533198

Comment 5 Fedora Update System 2008-06-17 19:35:48 UTC
gnome-settings-daemon-2.22.2.1-2.fc9 has been submitted as an update for Fedora 9

Comment 6 Fedora Update System 2008-06-20 19:12:12 UTC
gnome-settings-daemon-2.22.2.1-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-settings-daemon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5520

Comment 7 Fedora Update System 2008-07-30 20:12:18 UTC
gnome-settings-daemon-2.22.2.1-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.