Bug 431444

Summary: xrandr no longer works after recent updates
Product: [Fedora] Fedora Reporter: long
Component: xorg-x11-server-utilsAssignee: X/OpenGL Maintenance List <xgl-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-04 15:50:18 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
xorg.conf
none
Xorg.0.log none

Description long 2008-02-04 10:39:07 EST
Description of problem:
xrandr used to work fine.  I'm guessing one of the recent X updates broke it as
I don't re-login on a daily basis and that is the only time I use xrandr.  Now
when I run it xrandr reports the X server doesn't have the RANDR extension even
though Xorg.0.log reports it does.


Version-Release number of selected component (if applicable):
xorg-x11-server-utils-7.3-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Login to X
2. open terminal
3. run 'xrandr -v'
  
Actual results:
[long@griffon log]$ xrandr -v
Xlib:  extension "RANDR" missing on display ":0.0".
RandR extension missing


Expected results:
Tell me the RANDR version #?

Additional info:
I'm attaching my xorg.conf and Xorg.0.log
Comment 1 long 2008-02-04 10:39:07 EST
Created attachment 293898 [details]
xorg.conf
Comment 2 long 2008-02-04 10:39:51 EST
Created attachment 293899 [details]
Xorg.0.log
Comment 3 Dave Airlie 2008-02-04 15:50:18 EST
no xrandr and xinerama are incompatible...

either use randr 1.2 or drop xinerama...