This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 431854

Summary: Fedora 9 Alpha-Cable Internet Connection Fails After Update
Product: [Fedora] Fedora Reporter: Bob Agel <cragel>
Component: dhcpAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: jmoskovc
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-08 14:18:45 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
sysreport
none
updates 2/6/08
none
backtrace none

Description Bob Agel 2008-02-07 08:37:40 EST
Description of problem: During installation Roadrunner cable internet connection
properly configured.  After update 2/6/08, no internet connection and
system-config-network cannot restart it.


Version-Release number of selected component (if applicable): Rawhide (Fedora 9
Alpha)


How reproducible: Installation from DVD, normal updates; groupinstalled KDE but
no other new packages. 


Steps to Reproduce:
1. 
2.
3.
  
Actual results: Since update 2/6/08, eth0 cannot connect to internet. 
System-config-network fails with 'double free or corruption' and a backtrace
dump.  On advice of Rahul, I've first tried changing SELinux to Permissive mode
and even tried disabling it.  No change.  Network settings in
system-config-network are identical to working config in Fedora 8.

For help in identifying the problem, I've attached a sysreport and also updates
from 2/6


Expected results:


Additional info:
Comment 1 Bob Agel 2008-02-07 08:37:41 EST
Created attachment 294207 [details]
sysreport
Comment 2 Bob Agel 2008-02-07 08:38:29 EST
Created attachment 294208 [details]
updates 2/6/08
Comment 3 Jiri Moskovcak 2008-02-08 06:23:29 EST
Could you please post the backtrace?

Thank you,
Jirka
Comment 4 Bob Agel 2008-02-08 07:30:44 EST
Created attachment 294347 [details]
backtrace
Comment 5 Jiri Moskovcak 2008-02-08 07:41:53 EST
This looks more like bug in dhclient... So try to update (maybe downgrade) to 
another version. Assigning to dhclient.
Comment 6 Bob Agel 2008-02-08 08:28:09 EST
Jiri, you've nailed it.  There's a problem with the dhclient-4.0.0-7.fc9x86_64
and returning to the dhclient-4.0.0-6.fc9x86_64 (grabbed from the mirrors and
then installed with 'rpm -Uvh --force' allows system-config-network to restart
my connection.
Comment 7 David Cantrell 2008-02-08 14:18:45 EST
This is fixed in dhcp-4.0.0-9.fc9 and later.