Bug 431889

Summary: screen brightness goes to maximum - Intel graphics
Product: [Fedora] Fedora Reporter: Michael Sedkowski <msedkowski>
Component: xorg-x11-drv-i810Assignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 8CC: xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-12 11:13:59 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
xorg config file
none
xorg log none

Description Michael Sedkowski 2008-02-07 12:30:35 EST
Description of problem:
I own a HP NX6310 laptop with Intel 945GM Mobile graphics. When using the
'intel' driver the screen brightness goes to maximum each time I go to a text
console [CTRL+ALT+Fx], reboot or go into s2ram, s2disk no matter which level was
set previously using the keybord special keys or the xbacklight app.
The problem does not occur on the 'i810' driver, but the laptop fails to wake up
from s2ram while using the i810 so it's not an option. 

Version-Release number of selected component (if applicable):
2.1.1-7-fc8

How reproducible:
Always

Steps to Reproduce:
1.Go to a text console using crtl+alt+fx and back to X or
2.reboot or
3.go into s2ram/s2disk
  
Actual results:
Brightness is set to maximum

Expected results:
Brightness stays on the same level

Additional info:
If I delete the xorg.conf file, the system boots-up on the i810 driver so the
brightness problem does not appear but s2ram fails to work.
Comment 1 Michael Sedkowski 2008-02-07 12:30:35 EST
Created attachment 294231 [details]
xorg config file
Comment 2 Michael Sedkowski 2008-02-07 12:31:46 EST
Created attachment 294234 [details]
xorg log
Comment 3 Matěj Cepl 2008-02-07 13:24:18 EST
Well, how do you build mkinitrd -- Fedora doesn't support s2{ram,disk}, right?
Comment 4 Michael Sedkowski 2008-02-07 14:09:56 EST
Sorry my bad... I meant that when you go into suspend to ram or suspend to disk
via Gnome buttons from the 'shutdown window', the problem also appears.
I didn't modify the kernel or suspend scripts in any way.

I just moved from Debian to Fedora and I'm still thinking the Debian way ;-)
Comment 5 Matěj Cepl 2008-02-08 02:36:05 EST
That's OK, I went this way myself a year ago ;-)
Comment 6 Adam Jackson 2008-02-12 11:13:59 EST

*** This bug has been marked as a duplicate of 374691 ***