This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 432470

Summary: can not use & characters in sample configurations
Product: [Community] Publican Reporter: Murray McAllister <mmcallis>
Component: publicanAssignee: Murray McAllister <mmcallis>
Status: CLOSED NOTABUG QA Contact: Michael Hideo <mhideo>
Severity: low Docs Contact:
Priority: low    
Version: 2.0CC: mmcallis, publican-list, vdanen
Target Milestone: ---Keywords: Documentation
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-14 21:04:53 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Murray McAllister 2008-02-12 02:48:54 EST
Description of problem:
I need to use a "&amp;" character in a configuration file (not &). I can't get
this to parse correctly. I have tried:

* <screen><![CDATA[
* <programlisting>
* <literal>
* &amp;amp;

I would have thought the later worked. I got around this using "&amp;amp&semi;".
Not sure if this is correct...
Comment 1 Jeff Fearn 2008-02-14 21:04:53 EST
We do not support CDATA.

If you want to display xml content in your output, you need to:

mkdir en-US/extras
vi en-US/extras/foo.txt
<put your xml in foo.txt>

xi:include the txt file in to you xml file, in this case inside the screen tag:

<screen>
<xi:include parse="text" href="extras/foo.txt"
xmlns:xi="http://www.w3.org/2001/XInclude" />
</screen>

Cheers, Jeff.