This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 432671

Summary: Rhythmbox hijacks video files
Product: [Fedora] Fedora Reporter: Daniel Qarras <dqarras>
Component: shared-mime-infoAssignee: Bastien Nocera <bnocera>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 8Keywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-04 05:18:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Daniel Qarras 2008-02-13 13:19:32 EST
Description of problem:
Upgraded to rhythmbox-0.11.3-7.fc8+GNOME-2.20.3, rebooted, started GNOME
session, tried to open an MPEG video file. Previously Totem showed those files
all ok, now Rhythmbox hijacks them all but fails miserably as no video is shown,
only audio is sometimes played. Same happens with all other video type files.

And no, using System->Preferences->Personal->Preferred Applications does not work.

Version-Release number of selected component (if applicable):
rhythmbox-0.11.3-7.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Configure Totem as default multimedia app
2. Doubleclick on a video file, e.g., an MPEG file
3. See how Rhythmbox fails miserably to show any video
  
Actual results:
Rhythmbox is started but it just hangs or sometimes only plays audio. I am
frustrated.

Expected results:
Totem plays show my video clip.

Additional info:
I even removed all my settings under my home directory, started GNOME with clean
table, but still the problem persists.
Comment 1 Bastien Nocera 2008-03-26 08:24:38 EDT
I don't see that here. Does it still happen for you?
What's the mime-type nautilus gives you for the file (right-click->properties)?

Which version of shared-mime-info are you using?

If it shows up as something that's not an audio file, could you please get the
first 1000k of the file ("dd if=file.mpg of=test.mpg bs=1024 count=1000"), and
make them available?
Comment 2 Daniel Qarras 2008-03-27 13:31:42 EDT
Thanks for looking into this. With latest updates for Fedora 8 as of 2008-03-27
I still see this problem. To reproduce I did this:

# init 3
# useradd mrtest
# passwd mrtest
<logout everybody, login as mrtest>
$ startx
$ wget http://www.redhat.com/v/magazine/ogg/cox-issues.ogg

Properties for the file is video/x-theora+ogg. When double clicked, Rhythmbox is
trying to play it. If I open Totem and drag the file to it, video plays ok.

localhost:~> rpm -q shared-mime-info
shared-mime-info-0.23-1.fc8
localhost:~> rpm -V shared-mime-info
localhost:~> 
Comment 3 Bastien Nocera 2008-03-27 13:37:47 EDT
There's unfortunately nothing we can do here. Ogg files (video and/or audio)
used  to all have the .ogg suffix.

Rename your file to .ogv, and it should work as expected.
Comment 4 Daniel Qarras 2008-03-27 14:00:00 EDT
But this happens also with .mpg and .wmv files :(
Comment 5 Daniel Qarras 2008-03-27 14:01:18 EDT
And, yes, with .ogv. If I rename the file mentioned above, it is also opened
with Rhythmbox.
Comment 6 Fedora Update System 2008-03-27 18:36:27 EDT
shared-mime-info-0.23-2.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-03-28 09:58:07 EDT
shared-mime-info-0.23-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shared-mime-info'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2786
Comment 8 Daniel Qarras 2008-03-28 11:44:57 EDT
I'm happy to confirm that shared-mime-info-0.23-2.fc8 fixes the issue.

Thanks!
Comment 9 Bastien Nocera 2008-03-28 11:48:46 EDT
Leave a positive comment on the update page then.
Comment 10 Daniel Qarras 2008-10-04 05:18:24 EDT
Long since fixed and verified, closing.