Bug 432899

Summary: Missing UTF-8 support in slrn
Product: Red Hat Enterprise Linux 5 Reporter: Andreas Thienemann <athienem>
Component: slrnAssignee: Petr Pisar <ppisar>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.1Keywords: Rebase
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Version 0.9.9pl1 brings a lot of fixes and new features (UTF-8, Mail-Reply-To header, new slrn.sl macro file) added since version 0.9.8.1pl1. See http://slrn.sourceforge.net/docs/changes.txt for more details.
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-10-31 05:31:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Andreas Thienemann 2008-02-14 18:02:48 EST
slrn does not correctly show non-7-bit chars when running with a UTF-8
environment but shows them instead as <XX> chars.

<http://piggo.com/~troy/slrn#utf8> has some details about enabling it. Seems
current svn does support UTF-8. Could you please upgrade accordingly? Fedora is
shipping with UTF-8 enabled from several releases now.
Comment 1 Andreas Thienemann 2008-02-15 03:26:17 EST
sorry, this bug should have been against rhel, not against fedora. With F8 at
least, everything works fine.
Comment 2 RHEL Product and Program Management 2008-07-21 19:06:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 RHEL Product and Program Management 2010-08-09 15:33:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 Petr Pisar 2011-03-07 07:23:46 EST
UTF-8 support has been introduced in slrn-0.9.9. Rebase is needed to enable UTF-8 support. Current version in RHEL-5 is 0.9.8.1pl1.
Comment 7 Petr Pisar 2011-03-07 08:34:54 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Version 0.9.9pl1 brings a lot of fixes and new features (UTF-8, Mail-Reply-To header, new slrn.sl macro file) added since version 0.9.8.1pl1. See  http://slrn.sourceforge.net/docs/changes.txt for more details.
Comment 8 RHEL Product and Program Management 2011-09-22 20:18:24 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2012-06-11 21:07:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 Petr Pisar 2013-10-31 05:31:35 EDT
This report has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.