Bug 433290

Summary: IPv6 only installation problem in anaconda
Product: [Fedora] Fedora Reporter: A.J. Werkman <aj.werkman>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: cra, jonstanley, mark
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-21 16:23:48 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 195271, 235706    
Attachments:
Description Flags
Screen after installation use IPv6 only addressing scheme
none
Screenview from IPv6/IPv4 manual installation none

Description A.J. Werkman 2008-02-18 08:39:07 EST
Description of problem:
IPV6 addresses are not assigned to the requested interface by anaconda in the
installtion process.

Version-Release number of selected component (if applicable):
Fedora 9-Alpha anaconda 11.4.0.28

How reproducible:
Everytime

Steps to Reproduce:
1. Install F 9-Alpha from CD in a IPV6 only network in text mode
2. On the interface screen for the ethernet device deselect IPv4 support and
check IPv6 support
3. Select manual address configuration.
I use
Address: 2001:838:3ab:1::22/64
Default gw: 2001:838:3ab:1::1
DNS: 2001:838:3ab:1::1
  
Actual results:
After reboot the file /etc/sysconfig/network-scripts/ifcfg-eth0 contains the
line: IPV6ADDR = none. The file /etc/sysconfig/network contains the line
GATEWAY=2001:838:3ab:1::1
The ifconfig eth0 command does not show the proper IPv6 address.

Expected results:
The file /etc/sysconfig/network-scripts/ifcfg-eth0 should contain the line
IPV6ADDR=2001:838:3ab:1::22/64
The file /etc/sysconfig/network should contain the lines GATEWAY= and
IPV6_DEFAULTGW=2001:838:3ab:1::1
The command ifconfig eth0 should show the proper IPv6 address.


Additional info:
If I do a network installation intending to use a http installation I deselect
IPv4 and select IPv6 manual configuration. I use the addressing scheme:
Address: 2001:838:3ab:1::22/64
Default gw: 2001:838:3ab:1::1
DNS: 2001:838:3ab:1::1

The installation process stops with a: loader received SIGSEGV.

Apparently the IPv6 addressing scheme is badly addled by anaconda.
Comment 1 A.J. Werkman 2008-02-18 08:39:07 EST
Created attachment 295166 [details]
Screen after installation use IPv6 only addressing scheme
Comment 2 A.J. Werkman 2008-03-26 16:47:18 EDT
(In reply to comment #0)
This problem is still present in FC9Beta.


> 
> Additional info:
> If I do a network installation intending to use a http installation I deselect
> IPv4 and select IPv6 manual configuration. I use the addressing scheme:
> Address: 2001:838:3ab:1::22/64
> Default gw: 2001:838:3ab:1::1
> DNS: 2001:838:3ab:1::1
> 
> The installation process stops with a: loader received SIGSEGV.
> 
> Apparently the IPv6 addressing scheme is badly addled by anaconda.

Comment 3 A.J. Werkman 2008-03-26 17:01:32 EDT
I noticed that Bugzilla Bug 230949: Manual IPv6 configuration for network
install is broken at the end off the discussion addresses the same issue.
Comment 4 Jon Stanley 2008-04-16 13:16:58 EDT

*** This bug has been marked as a duplicate of 230949 ***
Comment 5 Mark McClelland 2008-04-16 20:18:39 EDT
There are two different issues here: the failure of the network install (same as
in Bug 230949), and the network misconfiguration after a successful install,
which is a different issue. I recall seeing config problems like this with a
v6-only system in F7-test1 (which I forgot to report). Please reopen.
Comment 6 David Cantrell 2008-04-18 19:50:13 EDT
This is fixed in rawhide.
Comment 7 A.J. Werkman 2008-04-21 06:11:47 EDT
Created attachment 303131 [details]
Screenview from IPv6/IPv4 manual installation

This screen does not make it possible to enter both IPv4 and IPv6 default
gateways and DNS server addresses. Neither is it obvious if you should fill in
IPv4 or IPv6 adressing schemes.
Comment 8 A.J. Werkman 2008-04-21 06:25:36 EDT
I tested this in rawhide anaconda version 11.4.0.74 dated 2008-04-20. I have
verified, that in a mixed IPv4 and IPv6 installation, using IPv4 DHCP and IPv6
automatic neighbour discovery, the correct network settings are taken to the
settings in /etc/sysconfig/network and
/etc/sysconfig/network-scripts/ifcfg-eth<?> files.

But as soon as I start to use fixed IPv6 addressing scheme in the installation,
although in most of the scenarios anaconda SIGFAULTS (but this is Bug 230949 I
believe), I noticed I can not give anaconda the proper IPv6 default gateway and
nameserver, as I have described in Comment #7. This makes it impossible for
anaconda to configure the above mentioned files properly.

So I don't think this bug is solved completely and should be reopend.
Comment 9 David Cantrell 2008-04-21 16:23:48 EDT
The bug you are encountering, as posted in your screenshot in comment #7, is bug 230949.  There are 
several issues related to the IPv6 configuration issues in anaconda.  Unfortunately, I won't be able to 
address all of them in F-9 because it's far to late to make user interface changes.  What I can do, is 
make what we have now work as best as possible and then fix things up in F-10.

In this bug, what was originally reported is the output to the /etc/sysconfig files was incorrect if you 
were doing IPv6-only networking.  I verified this and was able to see that, yes, anaconda was not 
writing the /etc/sysconfig files correctly when doing IPv6-only.  The values for those files are set 
during the network postinstall configuration screen, which is after the screen shot you have posted.  
During a graphical installer or text install, you will be asked later during installation what you want 
your network configuration settings to be.  This is done because some people may want different 
settings on the final system than what they used for installation.

On that screen, if you edit an individual interface and turn off IPv4 and switch IPv6 to manual and give it 
an address an prefix, the values written to /etc/sysconfig will be correct for the static IPv6 address.  
Also, the gateway field on the main screen will accept an IPv6 address (even though it's not obvious).  If 
you give it an IPv6 address, it will write that to /etc/sysconfig/network as IPV6_DEFAULTGW rather than 
GATEWAY.

So, based on the opening comments on this bug, the problem is solved.  Unfortunately, bug 230949 
(which I'm working on today) prevents you from doing an IPv6-only installation from the very 
beginning.  But, if you do an install using any other method or IPv4 networking, once you get to the 
network postinstall configuration screen, you can change things to IPv6 and have correct values written 
to /etc/sysconfig.

What I cannot do now is add another field to prompt for a separate IPv6 gateway.  I will be doing that 
once F-9 goes out.  It's too late to add user interface elements or string changes.

I am working on 230949, but this bug is done based on the original comment.  The fix for this bug will 
appear in anaconda-11.4.0.75-1.