Bug 433499

Summary: pam-0.99.8.1-17.fc8 breaks logins through kdm
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: pamAssignee: Tomas Mraz <tmraz>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-19 18:47:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Orion Poplawski 2008-02-19 17:53:05 UTC
Description of problem:

With the latest pam update, logins with kdm fail:

secure:
Feb 19 10:19:52 antero kdm: :0[2467]: PAM unable to
dlopen(/lib/security/pam_limits.so)
Feb 19 10:19:52 antero kdm: :0[2467]: PAM [error: /lib/libpam.so.0: version
`LIBPAM_MODUTIL_1.1' not found (required by /lib/security/pam_limits.so)]
Feb 19 10:19:52 antero kdm: :0[2467]: PAM adding faulty module:
/lib/security/pam_limits.so
Feb 19 10:19:52 antero kdm: :0[2467]: pam_unix(kdm:auth): authentication
failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=vanloon

messages:
Feb 19 10:20:13 antero kdm: :0[2467]: pam_open_session() for vanloon failed:
Module is unknown
Feb 19 10:20:13 antero kdm: :0[2467]: Client start failed
Feb 19 10:20:13 antero kdm: :0[2467]: pam_close_session() failed: Module is unknown

Version-Release number of selected component (if applicable):
pam-0.99.8.1-17.fc8

Why was this update pushed immediately to stable?

Comment 1 Tomas Mraz 2008-02-19 18:47:34 UTC
It wasn't, it was in testing for about two weeks. And nobody reported anything.

Your problem is also only intermittent - as soon as kdm is restarted (with the
new pam installed) it should disappear.