Bug 434994

Summary: Alt-Ctl-Del not handled - Can't login to WinXP
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: kvmAssignee: Jeremy Katz <katzj>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: berrange, clalance
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-02-26 14:05:38 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Tom London 2008-02-26 13:59:28 EST
Description of problem:
System appears not to "pass" Alt-Ctl-Del to the kvm VM.

When I run "qemu-kvm -m 400 image", image boots, and I get the WinXP "enter
Alt-Ctl-Del to start login" window.  But, I see no cursor displayed (unless I
move the cursor, and then only for a second or so), and when I enter
Alt-Ctl-Del, it appears to behave as if I had entered "Alt-Ctl" (that is, the
window loses the grab.

If I run this in full screen mode, still nothing happens when I enter Alt-Ctl-Del.

Reverting to kvm-60-2.fc9.i386.rpm does not fix.  Nor does putting SELinux into
permissive mode.

Version-Release number of selected component (if applicable):
kvm-61-2.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Berrange 2008-02-26 14:05:38 EST
The X server grabs the Ctrl-Alt-Del  keysequence before any application ever
gets a chance to see it. So its impossible to enter it, unless you use xmodmap
to completely remove X's grabbing of this key sequence.

The other alternative is to use  "Ctrl-Alt-2' to switch to QEMU's admin console
and use its 'send_key' command.

The further alternative is to start QEMU using virt-manager which has a menu
option for sending C-A-D - similarly virt-viewer provides this.

Comment 2 Tom London 2008-02-26 14:31:51 EST
OK. This just stopped working sometime near the end of last week so I thought
"something changed".

There were a lot of X changes, perhaps one of them "broke" this.
Comment 3 Tom London 2008-02-26 14:54:57 EST
I think this needs to be reopened.

qemu-kvm does not display the cursor now too. So even after using the suggested
Ctrl-Alt-2 method to send the key, I can login, but no cursor is display except
momentarily on mouse movement.

Since this is likely not a kvm issue (assuming X), a pointer here so I could
file a BZ properly would be appreciated!