Bug 435560

Summary: 2.21.92-2.fc9 memleak?
Product: [Fedora] Fedora Reporter: Mamoru TASAKA <mtasaka>
Component: nautilusAssignee: Tomáš Bžatek <tbzatek>
Status: CLOSED DEFERRED QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: medium    
Version: 9CC: jonstanley, s.adam, tbzatek, tsmetana
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-06 08:06:08 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705    
Attachments:
Description Flags
Memory usage of nautilus
none
Memory usage of nautilus
none
Memory usage of nautilus
none
Memory usage of nautilus
none
valgrind log of nautilus none

Description Mamoru TASAKA 2008-03-01 12:57:25 EST
Description of problem:
When I login to GNOME session, nautilus automatically runs
in backgroud. Then nautilus seems to eat more and more memory
as time passes.


Version-Release number of selected component (if applicable):
nautilus-2.21.92-2.fc9

How reproducible:
Seems 100%

Steps to Reproduce:
1. login to GNOME session
2. Watch the memory usage of nautilus
3.
  
Actual results:
Please see attached text

Additional info:
I guess this issue began to happen from 2.21.91 or  2.21.92?
Comment 1 Mamoru TASAKA 2008-03-01 12:57:25 EST
Created attachment 296456 [details]
Memory usage of nautilus
Comment 2 Matthias Clasen 2008-03-17 09:25:45 EDT
Are you still seeing this ? My nautilus memory usage is stable here...
Comment 3 Mamoru TASAKA 2008-03-17 10:45:19 EDT
Well, actually on yesterday this issue still existed so
I sent SIGSTOP to nautilus.

I will restart nautilus and report the result (after I wake up tomorrow).
Comment 4 Mamoru TASAKA 2008-03-18 07:08:17 EDT
Created attachment 298369 [details]
Memory usage of nautilus

ran 20 hours today.
Comment 5 Matthias Clasen 2008-04-05 10:52:30 EDT
Tomas, have you looked at this at all ? might be worth running nautilus under
valgrind for a while to see if anything suspicious shows up
Comment 6 Mamoru TASAKA 2008-04-06 05:01:00 EDT
Created attachment 301418 [details]
Memory usage of nautilus

Today's nautilus. Still seems a problem.
Comment 7 Mamoru TASAKA 2008-04-08 12:54:27 EDT
Created attachment 301659 [details]
Memory usage of nautilus

And today's nautilus (nautilus-2.22.2-1.fc9.i386)
Comment 8 Matthias Clasen 2008-04-09 12:18:55 EDT
Can you perhaps run nautilus under valgrind and see if that turns up anything ?

The way to do that is to remove nautilus from the session
(System>Preferences>Personal>Sessions, go to second tab, select nautilus, click
Remove, click Apply)

and then run

valgrind --leak-check=yes nautilus

in a terminal
Comment 9 Mamoru TASAKA 2008-04-09 23:28:06 EDT
Created attachment 301921 [details]
valgrind log of nautilus

Okay, about 7 hours run results of valgrind.
Comment 10 Jon Stanley 2008-04-18 04:50:58 EDT
This is a blocker that's not been touched in 7 days - any progress?
Comment 11 Bug Zapper 2008-05-14 01:43:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Stewart Adam 2008-08-13 10:28:34 EDT
I'm having similar problems with nautilus-2.23.6.1-1.fc10.x86_64 in rawhide.

I leave my machine running for days at a time, so nautilus just keeps using more and more memory. At the moment it's using 21.9% of 2GB! The problem seems to be much worse when viewing files with large file counts, maybe it caches the lists and file attributes? If so, there should be an expiry time or date for that cached information... Let me know if a valgrind report is needed.
Comment 13 Mamoru TASAKA 2008-12-06 08:06:08 EST
I don't use F-9 any longer so I cannot reproduce this issue by myself...

Closing DEFFERED for now...