Bug 436222

Summary: Unable to set X61s LCD panel brightness
Product: [Fedora] Fedora Reporter: Simon Karpen <simon>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-2.6.25-0.155.rc6.git8.fc9.x86_64 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-27 10:13:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Simon Karpen 2008-03-05 18:09:44 EST
Description of problem:
With kernel 2.6.25-0.87.rc3.git4.fc9 I am unable to set LCD panel brightness
(gnome-power-applet has the red circle with a line, works fine with
kernel-2.6.24.1-31.fc9.x86_64)

Version-Release number of selected component (if applicable):
2.6.25-0.87.rc3.git4.fc9


How reproducible:
100% reproducible


Steps to Reproduce:
1. Start X
2. Notice gnome power applet with red crossed out circle
3. Verify inability to change brightness
  
Actual results:
Unable to change display brightness

Expected results:
Able to set display brightness to desired level

Additional info:
Thinkpad X61s, Ultralight panel, Intel X3100 video, Rawhide current as of 3/5/08
Comment 1 Simon Karpen 2008-03-06 09:38:04 EST
Additional info:
- Bug is still present in kernel-2.6.25-0.93.rc4.fc9.x86_64
- When exiting X11 (I boot into text mode), the backlight is turned off and
won't come back on. (not even when I start X back up). This is also a regression
from 
kernel-2.6.24.1-31.fc9.x86_64.
Comment 2 Simon Karpen 2008-03-15 17:19:57 EDT
I've been trying to figure out where the breakage is here, and I do have some
hopefully useful info.

- The GNOME brightness applet shows the red circle unless I load the ACPI video
module before starting X. ('modprobe video')
- Even when the applet shows up normally, it doesn't work.
- In the kernels that work, there is a /proc/acpi/video/VID0 and a
/proc/acpi/video/VID1. In the kernels that don't work, there is a
/proc/acpi/video/VID. 
- Even echoing values to /proc/acpi/video/VID/LCD0/brightness doesn't actually
change the brightness at all.
- Full contents of /proc/acpi/video/VID/LCD0:

Contents of: brightness
levels:  100 100 20 25 30 35 40 45 50 55 60 65 70 75 80 85 90 100
current: 100

Contents of: EDID
<not supported>

Contents of: info
device_id:    0x0400
type:         UNKNOWN
known by bios: no

Contents of: state
state:     0x1f
query:     0x01


Also, since somebody will ask, I am running with selinux disabled, and the mode
settings works great in 2.6.24-31. 
Comment 3 Chuck Ebbert 2008-03-18 15:03:09 EDT
Probably caused by commit 0119509c4fbc9adcef1472817fda295334612976
"ACPI: video: Ignore devices that aren't present in hardware"
Comment 4 Chuck Ebbert 2008-03-18 15:04:00 EDT
What is in the VID0 and VID1 directories in the working kernels?
Comment 5 Simon Karpen 2008-03-18 15:25:19 EDT
It looks like it's VID and VID1 in 2.6.24-2.fc9, which is the only 2.6.24 I
could find for download (since it's the kernel for the F9 Alpha)

Please let me know if there's anything else you need. 

File ./VID1/DVI0/EDID contains:
<not supported>

File ./VID1/DVI0/brightness contains:
<not supported>

File ./VID1/DVI0/state contains:
state:     0x1d
query:     0x00

File ./VID1/DVI0/info contains:
device_id:    0x0210
type:         UNKNOWN
known by bios: no

File ./VID1/CRT0/EDID contains:
<not supported>

File ./VID1/CRT0/brightness contains:
<not supported>

File ./VID1/CRT0/state contains:
state:     0x0d
query:     0x00

File ./VID1/CRT0/info contains:
device_id:    0x0100
type:         UNKNOWN
known by bios: no

File ./VID1/LCD0/EDID contains:
  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U  U 
U  U  U  U  U  U
File ./VID1/LCD0/brightness contains:
levels:  100 100 20 25 30 35 40 45 50 55 60 65 70 75 80 85 90 100
current: 100

File ./VID1/LCD0/state contains:
state:     0x1f
query:     0x01

File ./VID1/LCD0/info contains:
device_id:    0x0110
type:         UNKNOWN
known by bios: no

File ./VID1/DOS contains:
DOS setting: <0>

File ./VID1/POST contains:
<not supported>

File ./VID1/POST_info contains:
<not supported>

File ./VID1/ROM contains:
<TODO>

File ./VID1/info contains:
Switching heads:              yes
Video ROM:                    no
Device to be POSTed on boot:  no

File ./VID/DVI0/EDID contains:
<not supported>

File ./VID/DVI0/brightness contains:
<not supported>

File ./VID/DVI0/state contains:
state:     0x1d
query:     0x00

File ./VID/DVI0/info contains:
device_id:    0x0300
type:         UNKNOWN
known by bios: no

File ./VID/CRT0/EDID contains:
<not supported>

File ./VID/CRT0/brightness contains:
<not supported>

File ./VID/CRT0/state contains:
state:     0x0d
query:     0x00

File ./VID/CRT0/info contains:
device_id:    0x0100
type:         UNKNOWN
known by bios: no

File ./VID/LCD0/EDID contains:
<not supported>

File ./VID/LCD0/brightness contains:
levels:  100 100 20 25 30 35 40 45 50 55 60 65 70 75 80 85 90 100
current: 100

File ./VID/LCD0/state contains:
state:     0x1f
query:     0x01

File ./VID/LCD0/info contains:
device_id:    0x0400
type:         UNKNOWN
known by bios: no

File ./VID/DOS contains:
DOS setting: <0>

File ./VID/POST contains:
<not supported>

File ./VID/POST_info contains:
<not supported>

File ./VID/ROM contains:
<TODO>

File ./VID/info contains:
Switching heads:              yes
Video ROM:                    no
Device to be POSTed on boot:  no
Comment 6 Chuck Ebbert 2008-03-18 19:50:16 EDT
(In reply to comment #3)
> Probably caused by commit 0119509c4fbc9adcef1472817fda295334612976
> "ACPI: video: Ignore devices that aren't present in hardware"

Patch will soon be reverted upstream.

Reverted in F8 kernel 2.6.24.3-43, hopefully that will fix this bug.
Comment 7 Simon Karpen 2008-03-18 20:26:12 EDT
I will test as soon as the fix makes it into rawhide. (running Rawhide, not F8)
Comment 8 Simon Karpen 2008-03-27 10:13:06 EDT
Works great in Rawhide. Marking resolved.