Bug 436726

Summary: no visible difference when number of updates changes
Product: [Fedora] Fedora Reporter: Jeremy Katz <katzj>
Component: gnome-packagekitAssignee: Robin Norwood <robin.norwood>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: richard
Target Milestone: ---Keywords: MoveUpstream
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-06 13:06:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
what i've merged into master none

Description Jeremy Katz 2008-03-09 19:23:06 EDT
When the number of updates changes, the user doesn't see any notification if
there were already updates available.  This means that if I don't install an
update (due to broken dependencies, for example), I don't see when more updates
are available.
Comment 1 Richard Hughes 2008-03-19 18:51:45 EDT
Sure, this is how I think it should be; other updates are still waiting to be
applied. What do you think PK should do in this instance?
Comment 2 Jeremy Katz 2008-03-19 19:08:22 EDT
It should give a notification.  Have you actually used the system that's been in
place for a while now?  A notification pops up when updates are available and
when the number of updates available changes.  The latter is very important (...
as I said initially) because the fact that you _left_ updates available may have
been due to broken deps or "I know this new version is broken/could break
something/some other reason" and yet now there's a new security update.  If
there's no notification that the state of things has changed, then the obvious
thing to think is that nothing has changed and only the updates you didn't want
are available.
Comment 3 Richard Hughes 2008-03-19 19:22:30 EDT
Looking at the code it should do exactly the same from x->y as from 0->y number
of updates. Could you post an output log of pk-update-icon when the number of
updates changes please - it seems to work for me. Thanks.
Comment 4 Jeremy Katz 2008-03-24 13:01:02 EDT
All I see is the icon in the notification area.  If I mouse over it, I can see
that the number is changed, but otherwise, no way to know.  Just looks like
another static icon in the ever-growing notification area :)
Comment 5 Richard Hughes 2008-04-15 18:28:49 EDT
Well, the libnotify box is only called when the number of _security_ updates
changes - the number of other updates do not cause a repeat notification. I
don't think it's a good idea to interrupt the user when low priority updates are
available; just let the auto-update thing or wait for the user to find a good
time to do updates. Do you disagree?
Comment 6 Jeremy Katz 2008-04-15 19:00:11 EDT
Updates are updates -- security might be somewhat more important, but bug fixes
can be equally important.  And if the user doesn't know the world has changed,
then they're not going to go click and see.
Comment 7 Richard Hughes 2008-04-16 12:24:38 EDT
No, I don't think we should pester the user with a libnotify window every time
the update list change. Can we not just pulse the icon for a few seconds or
Comment 8 Richard Hughes 2008-04-21 09:58:54 EDT
Created attachment 303149 [details]
Comment 9 Richard Hughes 2008-04-21 11:34:14 EDT
Created attachment 303161 [details]
what i've merged into master