Bug 437079

Summary: 'nohup' without an argument can also be used via pipe
Product: Red Hat Enterprise Linux 5 Reporter: Cai Xianchao <caixianchao>
Component: tcsh617Assignee: Vojtech Vitek <vvitek>
Status: CLOSED ERRATA QA Contact: BaseOS QE - Apps <qe-baseos-apps>
Severity: low Docs Contact:
Priority: low    
Version: 5.1CC: bnater, hripps, msvoboda, ovasik
Target Milestone: rcKeywords: ManPageChange
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
The tcsh(1) man page inaccurately stated that the "hup" and "nohup" built-in commands, when used without an argument, can be used only within a shell script. The man page has been corrected: it now states that the hup and nohup built-in commands can be used when running the shell non-interactively.
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-07-21 04:49:24 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
This is a patch fixing the bug.
none
Simple patch to fix 'nohup' section of man page none

Description Cai Xianchao 2008-03-12 02:59:20 EDT
Description of problem:

Manpage says that "Without  an  argument  (allowed  in only  a  shell 
script),", but it is allowed via pipe.

Version-Release number of selected component (if applicable):
tcsh-6.15.00

How reproducible:


Steps to Reproduce:
1.[test@localhost ~]$ nohup
nohup: Can't from terminal.

2.[test@localhost ~]$ echo 'nohup' | tcsh -l

  
Actual results:
An error message is outputed.

Expected results:
Nothing is outputed

Additional info:
Comment 1 Cai Xianchao 2008-03-12 02:59:20 EDT
Created attachment 297725 [details]
This is a patch fixing the bug.
Comment 2 Cai Xianchao 2008-03-12 03:07:08 EDT
I made a mistake.

"Actual results:" should be "Nothing is outputed.".
"Expected results:" should be "An error message is outputed.".
Comment 3 RHEL Product and Program Management 2011-01-11 14:57:57 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-12 10:14:33 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 5 Vojtech Vitek 2011-01-17 11:24:35 EST
Created attachment 473878 [details]
Simple patch to fix 'nohup' section of man page

Will be proposed to upstream.
Comment 10 Vojtech Vitek 2011-04-15 12:41:06 EDT
Proposed to upstream: http://bugs.gw.com/view.php?id=119
Comment 11 Vojtech Vitek 2011-04-18 04:26:59 EDT
Accepted by upstream (tcsh 6.17.07b).
Comment 13 Miroslav Svoboda 2011-07-01 17:47:03 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The tcsh(1) man page inaccurately stated that the "hup" and "nohup" built-in commands, when used without an argument, can be used only within a shell script. The man page has been corrected: it now states that the hup and nohup built-in commands can be used when running the shell non-interactively.
Comment 14 errata-xmlrpc 2011-07-21 04:49:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html
Comment 15 errata-xmlrpc 2011-07-21 08:09:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html