This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 438869

Summary: traceback when no network available
Product: [Fedora] Fedora Reporter: Jeremy Katz <katzj>
Component: PackageKitAssignee: Robin Norwood <robin.norwood>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: richard, tla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-28 22:03:54 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235706    

Description Jeremy Katz 2008-03-25 13:36:02 EDT
When starting pk-application with no network available, you get a long traceback
that doesn't at all make it clear that the problem is "your network isn't up,
you doofus"
Comment 1 Richard Hughes 2008-03-25 20:20:00 EDT
Hmm, we should be handling this more gracefully than just giving an error. Could
you post the output from "pk-application --verbose" when this happens please.
Thanks.
Comment 2 Jeremy Katz 2008-03-25 21:58:48 EDT
http://katzj.fedorapeople.org/pk-application-no-network.png is the screenshot of
the dialog that pops up.  -v output is
http://katzj.fedorapeople.org/pk-application-no-network.out
Comment 3 Richard Hughes 2008-03-28 22:03:54 EDT
Should be fixed with 0.1.10