Bug 438924

Summary: disk screen back and next buttons hard to click on
Product: [Fedora] Fedora Reporter: Peter F. Patel-Schneider <pfpschneider>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 10CC: lmacken
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: PR Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-01 16:54:47 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    
Attachments:
Description Flags
screenshot with problem
none
screenshot without problem none

Description Peter F. Patel-Schneider 2008-03-25 20:07:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080208 Fedora/2.0.0.12-1.fc8 Firefox/2.0.0.12

Description of problem:
In the screen that sets up the disks, the Back and Next buttons are hard to click on.  The only active parts of the buttons are thin strips at their top.

This is on a ThinkPad T60p with a 1600x1200 screen (as if that mattered).

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Boot Fedora 9 Beta Live from USB stick (probably doesn't matter)
2. Install to disk
3. Try to get out of the disk screen.

Actual Results:
If you click on the bulk of the buttons you instead toggle the click box at the bottom left.  Clicking on the very top of the buttons works.

Expected Results:
Clicking anywhere on the button should activate the button.

Additional info:
Not a biggy, but if it occurs on other machines, it will be very aggravating, and lead to *lots* of annoyed users.  It took me about 5 minutes to get past the screen.  I then even redid the installation and the problem reoccurred.
Comment 1 Jeremy Katz 2008-03-25 20:51:34 EDT
Luke saw this too today.  I'm planning to take a look
Comment 2 Peter F. Patel-Schneider 2008-03-25 22:20:17 EDT
The subtle highlighting on anaconda buttons exacerbates the problem - not that
I'm suggesting more blatant highlighting, but if there were so then it would
have been easier to see the hot spots.
Comment 3 Jeremy Katz 2008-04-16 23:19:26 EDT
I can't reproduce this now (although I'm trying on a different machine, same
video hardware and same resolution).  

Can you try with the preview release when it's released in a day or two and see
if it's better?  You don't even have to actually finish the install, just boot
and get to the screen in question.
Comment 4 Peter F. Patel-Schneider 2008-04-17 23:02:41 EDT
Will do, probably Friday (18 April) evening.
Comment 5 Jeremy Katz 2008-04-18 09:58:27 EDT
Thanks!
Comment 6 Peter F. Patel-Schneider 2008-04-18 21:10:09 EDT
Works fine now (but there is another issue with Anaconda having to do with disks
with mounted partitions - I'll look around and see if there is a bug filed on that).
Comment 7 Jeremy Katz 2008-04-20 18:27:39 EDT
Thanks for testing
Comment 8 Peter F. Patel-Schneider 2008-11-19 14:40:31 EST
This buglet has shown up again in the current F10 anaconda.
Comment 9 Jeremy Katz 2008-11-24 10:50:59 EST
Can you provide a screenshot of what you're seeing?  It's still looking okay to me.
Comment 10 Bug Zapper 2008-11-25 21:10:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Peter F. Patel-Schneider 2008-12-01 15:50:00 EST
Here are two screenshots.  One is from my desktop, screenshot.getafix, which is OK.  The other is from my ThinkPad T60p, screenshot.idefix, which exhibits the problem.  Note the different layout, which may be because the T60p has a 1600x1200 LCD.  It appears that the active area for the "Review and modify .." button extends all the way to the RHS of the window, obscuring most of the Back and Next buttons.
Comment 12 Peter F. Patel-Schneider 2008-12-01 15:51:14 EST
Created attachment 325293 [details]
screenshot with problem

This screenshot shows the layout that has the problem.
Comment 13 Peter F. Patel-Schneider 2008-12-01 15:52:07 EST
Created attachment 325294 [details]
screenshot without problem

This screenshot is from the install that is OK.
Comment 14 Peter F. Patel-Schneider 2008-12-01 15:55:00 EST
Oops.  The difference does not appear to be resolution based, but may be based on the DPI of the screen, which results in different sizes for the text, and thus different layout.
Comment 15 Jeremy Katz 2008-12-01 16:54:47 EST
Hmm, the font size in the one that's not working is not what I'd expect at all.  It's a different manifestation from on smaller form-factor machine's screens, though (where it's fixed and I did an install on one the other day and it was good with F10 final)

For this case, the changes that I made today to the text will fix things.