Bug 439225

Summary: 'yum groupinstall virtulization' does not install xen kernel
Product: [Fedora] Fedora Reporter: John Poelstra <poelstra>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideKeywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-27 12:50:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description John Poelstra 2008-03-27 12:23:36 EDT
Description of problem:

Running latest rawhide (2008-03-27) yum groupinstall virtulization does not
install xen kernel.  I believe in previous releases it was installed as part of
the dependency resolution process.

Is this an expected change in behaviour?  Note, xen-libs is still being installed.


# rpm -qa | egrep 'virt|xen' | sort
# yum groupinstall Virtualization
Setting up Group Process
Resolving Dependencies
--> Running transaction check
---> Package python-virtinst.noarch 0:0.300.3-1.fc9 set to be updated
--> Processing Dependency: libvirt-python >= 0.2.1 for package: python-virtinst
---> Package kvm.x86_64 0:63-2.fc9 set to be updated
---> Package virt-viewer.x86_64 0:0.0.3-1.fc9 set to be updated
--> Processing Dependency: libxenstore.so.3.0()(64bit) for package: virt-viewer
--> Processing Dependency: libvirt.so.0()(64bit) for package: virt-viewer
---> Package virt-manager.x86_64 0:0.5.4-2.fc9 set to be updated
---> Package qemu.x86_64 0:0.9.1-5.fc9 set to be updated
--> Running transaction check
---> Package libvirt-python.x86_64 0:0.4.1-4.fc9 set to be updated
---> Package xen-libs.x86_64 0:3.2.0-10.fc9 set to be updated
---> Package libvirt.x86_64 0:0.4.1-4.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 kvm                     x86_64     63-2.fc9         rawhide           818 k
 python-virtinst         noarch     0.300.3-1.fc9    rawhide           169 k
 qemu                    x86_64     0.9.1-5.fc9      rawhide            11 M
 virt-manager            x86_64     0.5.4-2.fc9      rawhide           1.2 M
 virt-viewer             x86_64     0.0.3-1.fc9      rawhide            28 k
Installing for dependencies:
 libvirt                 x86_64     0.4.1-4.fc9      rawhide           1.0 M
 libvirt-python          x86_64     0.4.1-4.fc9      rawhide            84 k
 xen-libs                x86_64     3.2.0-10.fc9     rawhide           156 k

Transaction Summary
=============================================================================
Install      8 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 14 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): python-virtinst-0. 100% |=========================| 169 kB    00:00     
(2/8): virt-manager-0.5.4 100% |=========================| 1.2 MB    00:00     
(3/8): virt-viewer-0.0.3- 100% |=========================|  28 kB    00:00     
(4/8): libvirt-python-0.4 100% |=========================|  84 kB    00:00     
(5/8): xen-libs-3.2.0-10. 100% |=========================| 156 kB    00:00     
(6/8): qemu-0.9.1-5.fc9.x 100% |=========================|  11 MB    00:00     
(7/8): kvm-63-2.fc9.x86_6 100% |=========================| 818 kB    00:00     
(8/8): libvirt-0.4.1-4.fc 100% |=========================| 1.0 MB    00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: xen-libs                     ######################### [1/8] 
  Installing: qemu                         ######################### [2/8] 
  Installing: libvirt                      ######################### [3/8] 
ln: creating symbolic link `/etc/libvirt/qemu/networks/autostart/default.xml':
File exists
  Installing: libvirt-python               ######################### [4/8] 
  Installing: virt-viewer                  ######################### [5/8] 
  Installing: kvm                          ######################### [6/8] 
  Installing: python-virtinst              ######################### [7/8] 
  Installing: virt-manager                 ######################### [8/8] 

Installed: kvm.x86_64 0:63-2.fc9 python-virtinst.noarch 0:0.300.3-1.fc9
qemu.x86_64 0:0.9.1-5.fc9 virt-manager.x86_64 0:0.5.4-2.fc9 virt-viewer.x86_64
0:0.0.3-1.fc9
Dependency Installed: libvirt.x86_64 0:0.4.1-4.fc9 libvirt-python.x86_64
0:0.4.1-4.fc9 xen-libs.x86_64 0:3.2.0-10.fc9
Complete!
# rpm -qa | egrep 'virt|xen' | sort
libvirt-0.4.1-4.fc9.x86_64
libvirt-python-0.4.1-4.fc9.x86_64
python-virtinst-0.300.3-1.fc9.noarch
virt-manager-0.5.4-2.fc9.x86_64
virt-viewer-0.0.3-1.fc9.x86_64
xen-libs-3.2.0-10.fc9.x86_64
Comment 1 Daniel Berrange 2008-03-27 12:27:30 EDT
This is not a bug. There is not Xen dom0 support in Fedora 9, so there is no
kernel-xen to install.
Comment 2 John Poelstra 2008-03-27 12:46:04 EDT
Then is this a bug?

# yum search kernel-xen
rawhide                   100% |=========================| 2.4 kB    00:00     
freshrpms                 100% |=========================| 1.9 kB    00:00     
============================= Matched: kernel-xen ==============================
kernel-xen-2.6-doc.noarch : Various documentation bits found in the kernel
                          : source
kernel-xen.x86_64 : The Linux kernel compiled for Xen VM operations
kernel-xen-devel.x86_64 : Development package for building kernel modules to
                        : match the Xen kernel
Comment 3 John Poelstra 2008-03-27 12:46:43 EDT
I installed it BTW and it doesn't boot :)
Comment 4 Daniel Berrange 2008-03-27 12:50:29 EDT
kernel-xen only supports DomU guests. It is non-functional on Dom0, hence not
booting. Dom0 support may be added as an update post-GA. cf these features for
F9 and F10

http://fedoraproject.org/wiki/Features/XenPvops
http://fedoraproject.org/wiki/Features/XenPvopsDom0