Bug 439325

Summary: no way to select multiple packages
Product: [Fedora] Fedora Reporter: Rahul Sundaram <sundaram>
Component: gnome-packagekitAssignee: Robin Norwood <robin.norwood>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: dakingun, richard, smohan, splewako
Target Milestone: ---Keywords: MoveUpstream
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-04 06:06:21 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Rahul Sundaram 2008-03-27 22:12:14 EDT
Description of problem:

If I have to select multiple package or package groups, I prefer to do select
them all by browsing the group list and installing them at one go instead of
select - install cycle that this UI supports. The use case is when I am about to
install a package group or package which I know is going to take a long time.
Even otherwise, I prefer batch processing packages and walking off my system
while package management software does the job instead of waiting on it one by one. 

Actual results

UI has no way to select multiple packages, package groups and doesn't
differentiate between optional packages and default packages.
Comment 1 Richard Hughes 2008-05-07 13:15:25 EDT
See http://www.packagekit.org/pk-help.html for the feature plan -- what you are
describing will be worked on during 0.2.1 and 0.2.2.
Comment 2 Bug Zapper 2008-05-14 04:21:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 3 Benjamin Vander Jagt 2008-05-16 23:09:47 EDT
A temporary workaround for me has been to "yum erase gnome-packagekit", "yum
install gnome-python2-gconf", and download and install the pirut RPM from the
Fedora 8 repository.  It seems to break nothing.
Comment 4 Richard Hughes 2008-05-22 12:28:45 EDT
- what do you guys think of that?
Comment 5 Rahul Sundaram 2008-05-22 16:44:25 EDT
I don't know how to describe this well but that looks a bit odd. I was hoping we
would come up something more interesting than check boxes again but this is a
much needed functionality and I would suggest pushing an update to rawhide and
updates-testing repository for Fedora 9 asap. When selecting multiple apps,
users just need a brief descriptions and the group information. Everything else
can be foldable. You can either provide that description when hovering over a
package or better yet a foldable tree view might work well. I think a third pane
for this is what I don't really like since it makes it somehow look like a
triple pane file manager from Mac OS X instead of a simple package manager. 
Comment 6 Richard Hughes 2008-07-04 06:06:21 EDT
Right, 0.2.3 should hit F9 in a few days/weeks time.