This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 439790

Summary: Fedora 9 beta Xen kernel boot failure
Product: [Fedora] Fedora Reporter: IBM Bug Proxy <bugproxy>
Component: xenAssignee: Xen Maintainance List <xen-maint>
Status: CLOSED DEFERRED QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: ia32e   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-03-31 09:28:49 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description IBM Bug Proxy 2008-03-31 09:16:29 EDT
=Comment: #0=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-26 22:40 EDT
Installed Fedora 9 with an Xen kernel, the grub boot entry has a wrong xen image
file name:
    kernel /boot/xen.gz-2.6.25-0.2.rc4.fc9
should be:
    kernel /boot/xen.gz-2.6.25-0.2.rc4.fc9xen

Other wise, grub complains with an 'Error 15: File not found' message

After booted to the correct xen image file, the system hangs. The screen shows
the following:
--------Start of the screen--------
(XEN)     virt_entry       = 0xc0776000
(XEN)  Xen  kernel: 32-bit, PAE, lsb
(XEN)  Dom0 kernel: 32-bit, PAE, lsb, paddr 0x400000 -> 0xacf000
(XEN) PHYSICAL MEMORY ARRANGEMENT:
(XEN)  Dom0 alloc:    000000003c000000->000000003e000000 (474508 pages to be
allocated)
(XEN) VIRTUAL MEMORY ARRANGEMENT:
(XEN)  Loaded kernel: c0400000->c0acf000
(XEN)  Init. ramdisk: c0acf000->c10da200
(XEN)  Phys-Mach map: c10db000->c12b2630
(XEN)  Start info:    c12b3000->c12b3474
(XEN)  Page tables:   c12b4000->c12c3000
(XEN)  Boot stack:    c12c3000->c12c4000
(XEN)  TOTAL:         c0000000->c1400000
(XEN)  ENTRY ADDRESS: c0776000
(XEN) Dom0 has maximum 2 VCPUs
(XEN) elf_load_binary: phdr 0 at 0xc0400000 -> 0xc0734000
(XEN) elf_load_binary: phdr 1 at 0xc0734000 -> 0xc0809a88
(XEN) Initrd len 0x60b200, start at 0xc0acf000
(XEN) Scrubbing Free RAM: .done.
(XEN) Xen trace buffers: disabled
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) Xen is relinquishing VGA console.
--------End of the screen-------------

Keyboard LED is not responsive to Numlock key press. I had to hard reset the
system to reboot.

Hardware Environment
    Machine type: IBM desktop 8212-KCG
    Cpu type: IA-32

Is this reproducible?
    Yes.
    Describe the steps:
    1. Install Fedora 9, make sure to select the Xen kernel and Xen support
packages.
    2. Boot to Xen kernel
=Comment: #2=================================================
Zhen Gang Li <lizg@cn.ibm.com> - 2008-03-27 06:02 EDT
I didn't select not to install the generic kernel. But the grub only comes with
a xen-kernel. So I'm not able to boot into the system. 'Tab' on the grub edit
prompt also shows that the /boot doesn't have the generic kernel.

See if the entry in grub helps since I cannot copy the grub.conf inside the system:
root (hd0,0)
kernel /boot/xen.gz-2.6.25-0.2.rc4.fc9
module /boot/vmlinuz-2.6.25-0.2.rc4.fc9xen ro
root=UUID=2d12d0e1-bade-4c9b-97c5-328d3602e0ad
module /boot/initrd-2.6.25-0.2.rc4.fc9xen.img

=Comment: #3=================================================
Suzuki Kp <suzukikp@in.ibm.com> - 2008-03-27 06:49 EDT
I am able to reproduce the issue locally. I tried both custom partition layout
as well as the automatic partitioning. Both didn't have an effect on this.

Debugging further.

Thanks

Suzuki
Comment 1 Daniel Berrange 2008-03-31 09:28:49 EDT
Xen dom0 is not supported in Fedora 9, only DomU guests will be supported

http://fedoraproject.org/wiki/Features/XenPvops

The xen.gz is left in the RPM since we may be able to re-introduce Dom0 support
post-GA, or in F10

http://fedoraproject.org/wiki/Features/XenPvopsDom0

Until that time though, it is expected that booting Xen will hang.
Comment 2 IBM Bug Proxy 2008-04-01 04:48:30 EDT
------- Comment From lizg@cn.ibm.com 2008-04-01 04:41 EDT-------
Suzuki,
Yes. That's where we can push. Thanks for the help!

Zhengang