Bug 440023

Summary: encryption failed
Product: [Fedora] Fedora Reporter: Marcela Mašláňová <mmaslano>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-23 23:46:43 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Marcela Mašláňová 2008-04-01 12:59:29 UTC
Description of problem:
The encryption freeze the installation.

Version-Release number of selected component (if applicable):
anaconda last F-9beta?

How reproducible:


Steps to Reproduce:
1. encrypt disk
2. type password, click ok
3. look on the frozen window
  
Actual results:
Anaconda freeze. After second try the disk want password because it "is"
encrypted. The password works and on the other try was installation successful
with encryption.

Expected results:
Encrypt disk on the first time without freeze.

Additional info:

Comment 1 David Lehman 2008-04-03 16:56:43 UTC
I haven't been able to duplicate this behavior in my testing.

Sometimes it takes several minutes to for disk encryption operations to
complete. This is not indicated anywhere in the user interface. Perhaps it was
just not done  yet, and it seemed as though anaconda had frozen?

Has this happened on more than one occasion? Can you perhaps provide more detail
about what you did, and also the symptoms of the perceived freeze?

Comment 2 Marcela Mašláňová 2008-04-04 08:23:40 UTC
After I type password and click OK, then nothing was happening for a quite long
time. The window with password should disappear and there should be something
like 'Encryption could take long time'. 
The second encryption was really fast and window for password disappear
immediately. 

It happened only once and I'm not planning new installation.

Comment 3 Bug Zapper 2008-05-14 08:31:08 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 David Lehman 2008-10-23 23:46:43 UTC
I was never able to duplicate this failure in testing and it has not been reported by any other users. Please feel free to reopen this bug if you experience this failure again.