Bug 440127

Summary: HP PSC1210 (hplip) doesn't print/scan
Product: [Fedora] Fedora Reporter: Klaus Pedersen <projectu>
Component: hplipAssignee: Tim Waugh <twaugh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: F-9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-02 08:12:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705    

Description Klaus Pedersen 2008-04-01 16:14:07 EDT
Description of problem:

Plugging in a HP Printer/Scanner PSC1210 to the USB port brings up a hotplug
message about "new printer psc_1200_series added". Output from hp-info seems to
indicate everything is OK. 

But printing a "Test Page" never create output, and xsane doesn't find the scanner.

Version-Release number of selected component (if applicable):

cups-1.3.6-7.fc9.i386
hplip-2.8.2-1.fc9.i386
selinux-policy-3.3.1-26.fc9.noarch
selinux-policy-targeted-3.3.1-26.fc9.noarch

How reproducible:
Everytime

Steps to Reproduce:
1. Plug in device
2. When Printer configuration dialog comes up - press "Press Test Page"
3. Wait... Wait... 

  
Actual results:
No print, but a yellow start from setroubleshooter...

Expected results:
A test page :-)

Additional info:

SELinux error: (setroubleshooter):

Summary
SELinux is preventing hp-makeuri (hplip_t) "read" to pipe (hald_t). 

Detailed Description
SELinux denied access requested by hp-makeuri. It is not expected that this
access is required by hp-makeuri and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access. 

Allowing Access
You can generate a local policy module to allow this access - see FAQ Or you can
disable SELinux protection altogether. Disabling SELinux protection is not
recommended. Please file a bug report against this package. 

Additional Information
Source Context:  system_u:system_r:hplip_t:s0
Target Context:  system_u:system_r:hald_t:s0
Target Objects:  pipe [ fifo_file ]
Source:  hp-makeuri
Source Path:  /bin/env
Source RPM Packages:  coreutils-6.10-16.fc9
Target RPM Packages:  
Policy RPM:  selinux-policy-3.3.1-26.fc9
...
Raw Audit Messages :
host=localhost.localdomain type=AVC msg=audit(1207068538.919:97): avc: denied {
read } for pid=28725 comm="hp-makeuri" path="pipe:[169110]" dev=pipefs
ino=169110 scontext=system_u:system_r:hplip_t:s0
tcontext=system_u:system_r:hald_t:s0 tclass=fifo_file

host=localhost.localdomain type=SYSCALL msg=audit(1207068538.919:97):
arch=40000003 syscall=11 success=yes exit=0 a0=8edd7e8 a1=8edc4b0 a2=8edd968
a3=0 items=0 ppid=28724 pid=28725 auid=4294967295 uid=0 gid=0 euid=0 suid=0
fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="hp-makeuri"
exe="/bin/env" subj=system_u:system_r:hplip_t:s0 key=(null) 

HP-INFO output:

# hp-info
HP Linux Imaging and Printing System (ver. 2.8.2)
Device Information Utility ver. 3.4

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hp:/usb/psc_1200_series?serial=MY35HC13JV5H

hp:/usb/psc_1200_series?serial=MY35HC13JV5H

Device Parameters (dynamic data):
  Parameter                     Value(s)                                       
          
 
--------------------------------------------------------------------------------------
  agent1-ack          False
  agent1-desc         Black cartridge
  agent1-dvc          0
  agent1-health       0
  agent1-health-desc  Good/OK
  agent1-hp-ink       False
  agent1-id           0
  agent1-kind         3
  agent1-known        False
  agent1-level        70
  agent1-level-trigger 0
  agent1-sku          56 (C6656AN)
  agent1-type         1    
  agent1-virgin       False
  agent2-ack          False
  agent2-desc         Tri-color cartridge
  agent2-dvc          0    
  agent2-health       0    
  agent2-health-desc  Low  
  agent2-hp-ink       False
  agent2-id           10
  agent2-kind         3
  agent2-known        False
  agent2-level        0
  agent2-level-trigger 5
  agent2-sku                    57 (C6657AN)/28 (C8728AN)
  agent2-type                   2
  agent2-virgin                 False
  back-end                      hp
  cups-printer                  psc_1200_series
  cups-uri                      hp:/usb/psc_1200_series?serial=MY35HC13JV5H
  dev-file             
  device-state                  1
  device-uri                    hp:/usb/psc_1200_series?serial=MY35HC13JV5H
  deviceid                      MFG:Hewlett-Packard;MDL:psc 1200
                 series;CMD:LDL,MLC,PML,DYN;CLS:PRINTER;1284.4DL:4d,4e,1;SN
                 :MY35HC13JV5H;S:0380008000820000002c1480046c2550000;      
  duplexer                      0
  error-state                   102
  host                                                                         
          
  in-tray1                      True
  in-tray2                      False
  is-hp                         True
  media-path                    2
  panel                         0
  panel-line1                                                                  
          
  panel-line2                                                                  
          
  photo-tray                    0
  port                          1
  r                             0
  revision                      3
  rg                            000
  rr                            000000
  rs                            000000000
  scan-uri                      hpaio:/usb/psc_1200_series?serial=MY35HC13JV5H
  serial                        MY35HC13JV5H
  status-code                   1502
  status-desc                   Tri-color cartridge is low on ink
  supply-door                   0
  top-door                      1

Model Parameters (static data):
  Parameter                     Value(s)                                       
          
 
--------------------------------------------------------------------------------------
  align-type                    6
  clean-type                    2
  color-cal-type                0
  copy-type                     0
  embedded-server-type          0
  fax-type                      0
  fw-download                   0
  icon                          psc_1100_series.png
  io-mfp-mode                   6
  io-mode                       1
  io-support                    2
  linefeed-cal-type             0
  model                         psc_1200_series
  model-ui                      HP PSC 1200 series
  model1                        PSC 1200
  model10                       PSC 1219
  model2                        PSC 1205
  model3                        PSC 1209
  model4                        PSC 1210
  model5                        PSC 1210v
  model6                        PSC 1210xi
  model7                        PSC 1215
  model8                        PSC 1216
  model9                        PSC 1217
  panel-check-type              0
  pcard-type                    0
  plugin                        0
  plugin-library
  power-settings                0
  pq-diag-type                  0
  r-type                        0
  r0-agent1-kind                3
  r0-agent1-sku                 56 (C6656AN)
  r0-agent1-type                1
  r0-agent2-kind                3
  r0-agent2-sku                 57 (C6657AN)/28 (C8728AN)
  r0-agent2-type                2
  scan-style                    1
  scan-type                     1
  status-battery-check          0
  status-dynamic-counters       0
  status-type                   2
  support-released              1
  support-type                  2
  support-ver                   0.9.5
  tech-class                    DJ3320
  tech-type                     2
  usb-pid                       2f11
  usb-vid                       03f0

Status History (most recent first):
  Date/Time             Code   Status Description                        User  
   Job ID  
  --------------------  -----  ---------------------------------------- 
--------  --------
  04/01/08 18:48:56     1502   Tri-color cartridge is low on ink         root
  04/01/08 18:48:56     1000   The printer is idle.                      root







/var/log/audit/audit.log

type=AVC msg=audit(1207068538.919:97): avc:  denied  { read } for  pid=28725
comm="hp-makeuri" path="pipe:[169110]" dev=pipefs ino=169110
scontext=system_u:system_r:hplip_t:s0 tcontext=system_u:system_r:hald_t:s0
tclass=fifo_file

type=SYSCALL msg=audit(1207068538.919:97): arch=40000003 syscall=11 success=yes
exit=0 a0=8edd7e8 a1=8edc4b0 a2=8edd968 a3=0 items=0 ppid=28724 pid=28725
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
tty=(none) ses=4294967295 comm="hp-makeuri" exe="/bin/env"
subj=system_u:system_r:hplip_t:s0 key=(null)

type=LABEL_LEVEL_CHANGE msg=audit(1207068577.360:98): user pid=1923 uid=0
auid=4294967295 subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023
msg='printer=psc_1200_series uri=hp:/usb/psc_1200_series?serial=MY35HC13JV5H
banners=none,none range=unknown: exe="/usr/sbin/cupsd"
(hostname=localhost.localdomain, addr=127.0.0.1, terminal=? res=success)'

type=LABEL_LEVEL_CHANGE msg=audit(1207068625.773:99): user pid=1923 uid=0
auid=4294967295 subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023
msg='printer=psc_1200_series uri=hp:/usb/psc_1200_series?serial=MY35HC13JV5H
banners=none,none range=unknown: exe="/usr/sbin/cupsd"
(hostname=localhost.localdomain, addr=127.0.0.1, terminal=? res=success)'

type=LABEL_LEVEL_CHANGE msg=audit(1207068625.793:100): user pid=1923 uid=0
auid=4294967295 subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023
msg='printer=psc_1200_series uri=hp:/usb/psc_1200_series?serial=MY35HC13JV5H
banners=none,none range=unknown: exe="/usr/sbin/cupsd"
(hostname=localhost.localdomain, addr=127.0.0.1, terminal=? res=success)'
Comment 1 Tim Waugh 2008-04-04 12:57:04 EDT
I think that hplip-2.8.2-2.fc9 might fix this.  If so, the problem was that the
/usr/share/hal/fdi/policy/10osvendor/10-hplip.fdi file needed to have "info.bus"
replaced by "info.subsystem".

With that change, HPLIP printing works here with current rawhide.

The symptom I saw when trying to reproduce this bug was that the test page
didn't print, although I did not get any SELinux messages.  However, while
writing this comment it's occurred to me that I tested with a device that was
not able to fax, and it is probably to do with fax-capable devices.
Comment 2 Tim Waugh 2008-04-04 13:11:38 EDT
Hmm, I just tried with an HP PSC 2210 and I didn't see any SELinux messages.

Do you still see them with these (or newer) packages?:

selinux-policy-3.3.1-26.fc9
hplip-2.8.2-2.fc9
hal-cups-utils-0.6.16-3.fc9
Comment 3 Bug Zapper 2008-05-14 04:32:56 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tim Waugh 2008-06-02 08:12:23 EDT
No feedback; assuming fixed.