Bug 441598

Summary: Install crashes with traceback - The name org.freedesktop.Hal was not provided by any .service files
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-11 14:02:03 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    
Attachments:
Description Flags
ps -fe none

Description Orion Poplawski 2008-04-08 17:43:02 EDT
Description of problem:

Trying pxe/kickstart text mode install of today's rawhide.  Worked on one
laptop, on another I get:

File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 607, in
call_blocking
  message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The
anme org.freedesktop.Hal was not provided by any .service files

Main difference is that I'm trying to re-use the /boot, swap, and /export
partitions from an existing install.

Version-Release number of selected component (if applicable):
11.4.0.66
Comment 1 Orion Poplawski 2008-04-08 17:47:21 EDT
Hmm, removed a CD-ROM disc that was in the machine and it seems to get past that
now. 
Comment 2 Jeremy Katz 2008-04-08 20:35:35 EDT
If you can reproduce, does it look like hal is running when you get the traceback?
Comment 3 Orion Poplawski 2008-04-08 22:17:57 EDT
Very reproducible.  hald has been running the whole time.
Comment 4 Orion Poplawski 2008-04-08 22:19:13 EDT
Gah, sorry - got this mixed up with another bug.  I'll see if I can check - but
it crashes very quickly...
Comment 5 Orion Poplawski 2008-04-09 12:35:25 EDT
Created attachment 301844 [details]
ps -fe

Okay, with nokill I can still use VT2.	hald is definitely running.  Perhaps it
is taking too long to come up pinging the CDROM?
Comment 6 Jeremy Katz 2008-04-09 15:22:38 EDT
Is the cd being used for the kickstart as a source?  Also, where is the dbus
call being made (ie, what's the rest of the traceback)
Comment 7 Orion Poplawski 2008-04-09 15:42:15 EDT
The cd just happened to be in the drive (though it is a Fedora CD).  I'm doing a
PXE boot, http install.  Rest of the traceback scrolls off the screen.  Last
item in anaconda.log is:

09:58:11 INFO    : Display mode = t
09:58:11 INFO    : Method =
http://fedora.cora.nwra.com/fedora/linux/development/i386/os
Comment 8 Jeremy Katz 2008-04-09 15:57:09 EDT
The only callers of it that I see in a quick grep are wrapped in try/except. 
And shift-pgup should work to scrollback and see more of the traceback.
Comment 9 Orion Poplawski 2008-04-09 16:18:01 EDT
Ah, never knew about shift-pgup.  cool.

/usr/bin/anaconda line 869 in probeHW
                  line 456 in xserver.probeHW
 rhpxl/xserver.py line 84
 rhpxl/videocard.py line 126

Comment 10 Jeremy Katz 2008-04-09 21:32:34 EDT
Hrmm -- definitely should be running at that point.  Sticking on the blocker
list so that we can not lose track of this
Comment 11 Jerry Vonau 2008-04-09 21:45:27 EDT
Cool, I thought it was just me.... I saw this earlier with 11.4.0.65 also. 
I also saw after the above:

/dbus/bus.py line 244 get_object
/dbus/proxies.py line 241 __init__
/dbus/bus.py line 183 activate_name_owner
/dbus/bus.py line 281 start_service_by_name

then /dbus/connection.py", line 607 

hope it helps.
Comment 12 Jerry Vonau 2008-04-11 10:25:33 EDT
fixed with 11.4.0.71 for me.

Comment 13 Orion Poplawski 2008-04-11 14:02:03 EDT
And for me.. Looks like the new rhpxl package fixed it.