Bug 442300

Summary: gdm shows password in typeahead find popup
Product: [Fedora] Fedora Reporter: Mikel Ward <mikel>
Component: gdmAssignee: jmccann
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: cschalle, lsof, rstrode, wtogami, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gdm-2.21.10-0.2008.04.28.1.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-29 14:47:28 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235706    

Description Mikel Ward 2008-04-13 22:24:57 EDT
The new version of gdm is painfully slow on my system.

If I type my username and press Enter (or just press Enter when my picture is
selected), then immediately continue typing my password before gdm draws the
password field (which takes about a second), it appears verbatim in a GTK
typeahead find popup.
Comment 1 Mikel Ward 2008-04-13 22:28:05 EDT
Just so you know, I'm on a Dell Core2 Duo laptop with an nVidia Quadro NVS 135M
video card using the open source "nv" driver.  The whole X system is a little
sluggish, but this is the only place where it's a major issue.
Comment 2 Ray Strode [halfline] 2008-04-14 00:07:01 EDT
Hi,

So we should probably do two things

1) disable type ahead after the user presses enter
2) maybe queue up keystrokes and replay them when the password prompt comes up
like we do for gnome-screensaver's lock dialog.
Comment 3 Warren Togami 2008-04-16 17:26:07 EDT
#2 sounds like a good idea, but make sure it flushes additional key presses
after it cancels out of a password dialog, if you know what I mean.
Comment 4 Matthias Clasen 2008-04-17 01:08:13 EDT
* Wed Apr 16 2008 Ray Strode <rstrode@redhat.com> - 1:2.21.10-0.2008.04.16.1
- Disable typeahead when asking for password so password can't get shown
  in clear text (bug 442300)
Comment 5 Bill Nottingham 2008-04-21 17:42:38 EDT
This seems to work now for me. Can you retest?
Comment 6 Ray Strode [halfline] 2008-04-21 17:51:24 EDT
I don't do the part 2) queueing yet.
Comment 7 jmccann 2008-04-28 16:52:04 EDT
*** Bug 442243 has been marked as a duplicate of this bug. ***
Comment 8 Ray Strode [halfline] 2008-04-29 00:09:19 EDT
Hi Mikel,

Mind giving gdm-2.21.10-0.2008.04.28.1.fc9
(http://koji.fedoraproject.org/koji/buildinfo?buildID=47545) a spin? 

It should be faster, disable the type ahead pop up, and queue key strokes made
during the animation for after the animation finishes.
Comment 9 Mikel Ward 2008-04-29 02:04:53 EDT
It didn't disable the typeahead find during the user selection, but I assume you
just meant after Enter is pressed.

I can't reproduce the problem any more, so it's fixed as far as I can tell.
Comment 10 Ray Strode [halfline] 2008-04-29 09:43:59 EDT
That's right.  Thanks, I'll request it gets tagged.
Comment 11 Will Woods 2008-04-29 14:47:28 EDT
Tagged and signed; should appear in tomorrow's rawhide.