Bug 442358

Summary: Bridged networking not working with KVM guest
Product: [Fedora] Fedora Reporter: Christian Ambach <cambach1>
Component: libvirtAssignee: Daniel Veillard <veillard>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 8CC: berrange, p.van.egdom
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-29 09:54:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Christian Ambach 2008-04-14 11:16:47 EDT
Description of problem:
When using bridged networking in KVM guest, it does not work with the latest
libvirt versions any more. I had to downgrade to to make it working again.



Version-Release number of selected component (if applicable):
latest (0.4.1)

How reproducible:

Create a KVM guest and configure bridging to an external device as network
interface.

Actual results:
The guest cannot access the external network and the kernel outputs lots of
errors in dmesg

Apr 14 11:33:37 terra kernel: RTNL: assertion failed at net/core/fib_rules.c (627)
Apr 14 11:33:37 terra kernel: Pid: 2371, comm: libvirtd Not tainted
2.6.24.4-64.fc8 #1
Apr 14 11:33:37 terra kernel:  [<c05d38ab>] fib_rules_event+0x4a/0xf1
Apr 14 11:33:37 terra kernel:  [<c062ddb9>] notifier_call_chain+0x2a/0x47
Apr 14 11:33:37 terra kernel:  [<c04427b8>] raw_notifier_call_chain+0x17/0x1a
Apr 14 11:33:37 terra kernel:  [<c05c7579>] dev_set_mac_address+0x43/0x48
Apr 14 11:33:37 terra kernel:  [<f8ad4608>] tun_chr_ioctl+0x435/0x4dd [tun]
Apr 14 11:33:37 terra kernel:  [<c04930cc>] do_ioctl+0x4c/0x62
Apr 14 11:33:37 terra kernel:  [<c0493319>] vfs_ioctl+0x237/0x249
Apr 14 11:33:37 terra kernel:  [<c0493370>] sys_ioctl+0x45/0x5d
Apr 14 11:33:37 terra kernel:  [<c04051da>] syscall_call+0x7/0xb
Apr 14 11:33:37 terra kernel:  [<c0620000>] xfrm_send_migrate+0x13/0x236
Apr 14 11:33:37 terra kernel:  =======================
Apr 14 11:33:37 terra kernel: RTNL: assertion failed at net/ipv4/devinet.c (1054)
Apr 14 11:33:37 terra kernel: Pid: 2371, comm: libvirtd Not tainted
2.6.24.4-64.fc8 #1
Apr 14 11:33:37 terra kernel:  [<c0606099>] inetdev_event+0x56/0x46e
Apr 14 11:33:37 terra kernel:  [<c062c1ae>] _spin_lock_bh+0x8/0x18
Apr 14 11:33:37 terra kernel:  [<c05e0815>] rt_run_flush+0x68/0x8f
Apr 14 11:33:37 terra kernel:  [<c062ddb9>] notifier_call_chain+0x2a/0x47
Apr 14 11:33:37 terra kernel:  [<c04427b8>] raw_notifier_call_chain+0x17/0x1a
Apr 14 11:33:37 terra kernel:  [<c05c7579>] dev_set_mac_address+0x43/0x48
Apr 14 11:33:37 terra kernel:  [<f8ad4608>] tun_chr_ioctl+0x435/0x4dd [tun]
Apr 14 11:33:37 terra kernel:  [<c04930cc>] do_ioctl+0x4c/0x62
Apr 14 11:33:37 terra kernel:  [<c0493319>] vfs_ioctl+0x237/0x249
Apr 14 11:33:37 terra kernel:  [<c0493370>] sys_ioctl+0x45/0x5d
Apr 14 11:33:37 terra kernel:  [<c04051da>] syscall_call+0x7/0xb
Apr 14 11:33:37 terra kernel:  [<c0620000>] xfrm_send_migrate+0x13/0x236
Apr 14 11:33:37 terra kernel:  =======================
Apr 14 11:33:37 terra kernel: device vnet0 entered promiscuous mode
Apr 14 11:33:37 terra kernel: audit(1208165617.622:6): dev=vnet0 prom=256
old_prom=0 auid=4294967295
Apr 14 11:33:37 terra kernel: eth0: port 2(vnet0) entering learning state
Apr 14 11:33:37 terra kernel: kvm: guest NX capability removed
Apr 14 11:33:39 terra avahi-daemon[2389]: Registering new address record for
fe80::219:3fff:fe4b:388d on vnet0.*.
Apr 14 11:33:52 terra kernel: eth0: topology change detected, propagating
Apr 14 11:33:52 terra kernel: eth0: port 2(vnet0) entering forwarding state
Apr 14 11:34:18 terra kernel: vnet0: received packet with  own address as source
address
Apr 14 11:34:55 terra kernel:last message repeated 10 times
Apr 14 11:35:44 terra kernel:last message repeated 12 times
Apr 14 11:35:44 terra kernel: printk: 1 messages suppressed.
Apr 14 11:35:44 terra kernel: vnet0: received packet with  own address as source
address


Expected results:
The guest can access the external network.

Additional info:
Comment 1 Christian Ambach 2008-04-15 04:50:45 EDT
retested with latest build libvirt-0.4.2-1.fc8 from koji, seems to be fixed in
that version

that version is not available via yum update yet
Comment 2 Peter van Egdom 2008-06-29 09:54:05 EDT
Thanks for reporting back. Closing bug as per comment #1.

Fedora release 9 (+ updates) contains "libvirt-0.4.2-3.fc9".