Bug 442397

Summary: Radio stream have small interruptions
Product: [Fedora] Fedora Reporter: antonio montagnani <antonio.montagnani>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: lordmorgul
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-21 21:59:04 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description antonio montagnani 2008-04-14 13:22:02 EDT
Description of problem:

when I connect to a radio after last updates I am experiencing small
interruptions as buffer is empty...

Version-Release number of selected component (if applicable):
rhythmbox-0.11.5-9.fc9

How reproducible:
always
Steps to Reproduce:
1.connect to radioswisspop (http://www.radioswisspop.ch/live/mp3.m3u)
2.
3.
  
Actual results:
small interruptions

Expected results:
smooth playing as before

Additional info:
Comment 1 antonio montagnani 2008-04-26 13:19:48 EDT
and this happens after a while, i.e. for example first song is o.k, then I am
experiencing small breaks in streams as buffer is empty.

Maybe connected to some gstreamer-plugin and not to rhythmbox???? I wish I knew
how stream are managed in Fedora....
Comment 2 antonio montagnani 2008-04-27 12:38:04 EDT
I am experiencing same troubles with Audacious, i.e. bug has to be assigned to
some other component.No idea what is causing trouble.
Maybe alsa-lib???
Comment 3 Bastien Nocera 2008-04-28 07:19:25 EDT
Or maybe your internet connection isn't fast enough?

You can try "gst-launch-0.10 playbin uri=http://swisspop.stream.sunrise.ch:8000"
to replicate the problem outside Rhythmbox. If the problem still happens, it's
likely to be a problem with GStreamer or one of the plugins, or your internet
connection simply not keeping up.
Comment 4 antonio montagnani 2008-04-28 12:40:23 EDT
My Internet connection is o.k. (more that 14M) :Another PC on same network is
o.k.....with similar setup (apart from the sound card)

I have the following packages installed
$ rpm -qa gstreamer*
gstreamer-plugins-base-0.10.19-2.fc9.i386
gstreamer-plugins-schroedinger-1.0.0-1.fc9.i386
gstreamer-plugins-base-devel-0.10.19-2.fc9.i386
gstreamer-python-0.10.11-2.fc9.i386
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
gstreamer-ffmpeg-0.10.3-4.lvn9.i386
gstreamer-devel-0.10.19-1.fc9.i386
gstreamer-plugins-good-0.10.7-2.fc9.i386
gstreamer-plugins-ugly-0.10.7-1.lvn9.i386
gstreamer-plugins-bad-extras-0.10.6-3.lvn9.i386
gstreamer-tools-0.10.19-1.fc9.i386
gstreamer-0.10.19-1.fc9.i386
gstreamer-plugins-bad-0.10.6-3.lvn9.i386
gstreamer-plugins-farsight-0.12.6-1.fc9.i386
gstreamer-plugins-bad-devel-0.10.6-3.lvn9.i386

rhythmbox-0.11.5-9.fc9.i386
alsa-lib-devel-1.0.16-3.fc9.i386
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
alsa-lib-1.0.16-3.fc9.i386
alsa-tools-1.0.16-1.fc9.i386
alsa-utils-1.0.16-2.fc9.i386

and it was working before some updates some time ago, but who knows what broke it.

I am running music according to your suggestion and I will report if any
breakage will be seen.

Tnx for help
Comment 5 antonio montagnani 2008-04-28 12:42:13 EDT
same breaks after a while (like buffer refilling...)
Comment 6 antonio montagnani 2008-04-28 12:43:49 EDT
This is what I see in my terminal. Sorry but if it is in Italian

gst-launch-0.10 playbin uri=http://swisspop.stream.sunrise.ch:8000
Impostazione della pipeline a PAUSED ...
La pipeline è in PREROLLING ...
La pipeline è in PREROLLED ...
Impostazione della pipeline a PLAYING ...
New clock: GstAudioSinkClock
Riempimento buffer, impostazione della pipeline a PAUSED ...
Riempimento buffer completato, impostazione della pipeline a PLAYING ...
Riempimento buffer, impostazione della pipeline a PAUSED ...
Riempimento buffer completato, impostazione della pipeline a PLAYING ...
Riempimento buffer, impostazione della pipeline a PAUSED ...
Riempimento buffer completato, impostazione della pipeline a PLAYING ...
Comment 7 antonio montagnani 2008-04-28 16:49:51 EDT
for the working system:

rpm -qa gstreamer*
gstreamer-plugins-base-0.10.19-1.fc9.i386
gstreamer-plugins-farsight-0.12.6-1.fc9.i386
gstreamer-0.10.19-1.fc9.i386
gstreamer-plugins-ugly-0.10.7-1.lvn9.i386
gstreamer-plugins-bad-extras-0.10.6-3.lvn9.i386
gstreamer-ffmpeg-0.10.3-4.lvn9.i386
gstreamer-plugins-good-0.10.7-1.fc9.i386
gstreamer-python-0.10.11-2.fc9.i386
gstreamer-devel-0.10.19-1.fc9.i386
gstreamer-plugins-base-devel-0.10.19-1.fc9.i386
gstreamer-plugins-bad-0.10.6-3.lvn9.i386
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
gstreamer-plugins-bad-devel-0.10.6-3.lvn9.i386
gstreamer-tools-0.10.19-1.fc9.i386
gstreamer-plugins-schroedinger-1.0.0-1.fc9.i386
gstreamer-plugins-good-devel-0.10.7-1.fc9.i386
[antonio@acer ~]$ rpm -qa alsa*
alsa-lib-1.0.16-3.fc9.i386
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
alsa-utils-1.0.16-2.fc9.i386 

Furthermore sound cars is defined as:

alias snd-card-0 snd-hda-intel
options snd-card-0 index=0 model=acer
options snd-hda-intel index=0 

In the other system (the non working system) sound card is defined as:

alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
alias snd-card-1 snd-mpu401
options snd-card-1 index=1
options snd-mpu401 index=1

Please note that this system was working not a long ago...
Comment 8 antonio montagnani 2008-04-29 16:21:29 EDT
I played two systems (as reported in other comments) alongside, and one is
experiencing small breaks while the other is playing fine (I note that the
system that is not suffering from breaks suffers of a small delay- as when you
have echo, i.e. same station is tuned and one system is about half a second
delayed after the other one!!!!)
I don't know if it is connected..... 
Funny that the systems suffering from breaks is directly connecetd to the net
while the other system is connected through the first one actin as router...
Comment 9 antonio montagnani 2008-04-29 17:06:37 EDT
even the player inside Firefox suffers of same breaks....(for example for YouTube)
Comment 10 antonio montagnani 2008-04-30 06:13:27 EDT
I run an additional test.

I started the suffering machine and after the laptop.
I see that music played on the suffering machine was delayed in comparison with
the other machine (about 6 seconds), then the two machines played simultaneous,
then the suffering machine played  ahead of the laptop, and buffer started to be
empy and refilled.

What is wrong???
Comment 11 Bastien Nocera 2008-04-30 09:28:18 EDT
Is Pulseaudio running and enabled? Do you see the same problem playing sound
using another program, such as using "mplayer
http://swisspop.stream.sunrise.ch:8000/"?
Comment 12 antonio montagnani 2008-05-01 12:06:56 EDT
How do I check if Pulseaudio is running and enabled???
Test with mplayer will be run only on Sunday evening, as I am not at home!!

Tnx
Comment 13 Bastien Nocera 2008-05-01 13:08:49 EDT
(In reply to comment #12)
> How do I check if Pulseaudio is running and enabled???

To show if pulseaudio is running:
ps aux | grep pulseaudio
To see if the right plugins are installed:
rpm -qa "*pulse*"

Comment 14 antonio montagnani 2008-05-04 12:02:17 EDT
ps aux | grep pulseaudio
antonio   2961  0.0  0.5  34640  5416 ?        S<l  17:51   0:00
/usr/bin/pulseaudio --log-target=syslog
antonio   4182  0.0  0.0   4148   776 pts/0    R+   18:01   0:00 grep pulseaudio

rpm -qa "*pulse*"
pulseaudio-utils-0.9.10-1.fc9.i386
pulseaudio-module-x11-0.9.10-1.fc9.i386
pulseaudio-0.9.10-1.fc9.i386
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
pulseaudio-libs-0.9.10-1.fc9.i386
pulseaudio-libs-glib2-0.9.10-1.fc9.i386
pulseaudio-libs-devel-0.9.10-1.fc9.i386
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
pulseaudio-core-libs-0.9.10-1.fc9.i386
pulseaudio-libs-zeroconf-0.9.10-1.fc9.i386
pulseaudio-module-zeroconf-0.9.10-1.fc9.i386
pulseaudio-module-jack-0.9.10-1.fc9.i386
pulseaudio-esound-compat-0.9.10-1.fc9.i386
xine-lib-pulseaudio-1.1.12-2.fc9.i386
pulseaudio-module-gconf-0.9.10-1.fc9.i386
Comment 15 antonio montagnani 2008-05-04 12:18:39 EDT
 mplayer http://swisspop.stream.sunrise.ch:8000/
MPlayer SVN-r25979 rpm.livna.org (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 3.00GHz (Family: 15, Model: 4, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
The flip-hebrew option can't be used in a config file.
Error parsing option flip-hebrew=no at line 133

Comment 16 antonio montagnani 2008-05-04 12:47:57 EDT
I add my SMOLT profile, if it can help

uuid=pub_2dabf29b-bd26-4825-b7ed-ac1db85fec24

I have same problems after upgrading to latest updates as per 17.00 UTC.
Comment 17 antonio montagnani 2008-05-04 14:43:12 EDT
May it be connected to Bug 441087 Sound/music playing faster than it should on
intel chipset ????
Comment 18 antonio montagnani 2008-05-05 15:41:54 EDT
I think that also Skype is affected....
Comment 19 antonio montagnani 2008-05-05 16:31:54 EDT
I have run also this test:

I played a MP3 song (6.15) and I strated my chrono and I got 6:02, so it seems
that is about 13 seconds faster than due.
Comment 20 antonio montagnani 2008-05-06 16:14:55 EDT
I think that component to be blamed is kernel!!!! and I think that is connected
to Intel chip, see also Bugzilla Bug 444388: Sound lag issues with pulseaudio
and Bugzilla Bug 441087: Sound/music playing faster than it should on intel
chipset, in each of them I see Intel chip!!!!

 
My /sbin/lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500]
(rev a1)
02:05.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit
Ethernet Controller (rev 13)
02:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
02:0d.0 Network controller: AVM Audiovisuelles MKTG & Computer System GmbH A1
ISDN [Fritz] (rev 02)
Comment 21 Andrew Farris 2008-05-06 19:11:29 EDT
Antonio/Bastien,
I can reproduce this bug with my intel integrated ac97 chipset.  Furthermore...
I can demonstrate that gstreamer or internet speed is not to blame by using the
pulseaudio pavucontrol to switch the stream output device while it is playing.

When I select my intel chipset as the output device there will be buffering
glitches in the playback every 10-15 seconds, but when I change the output
device to sb audigy the playback buffering is smooth and continuous.  I can
repeatedly demonstrate changing back and forth between devices and seeing the
buffering problem start and stop while the stream has not been disconnected. 
This is duplicated with a premium service stream I regularly use as well so I
don't think its a network load issue at all.

I would recommend changing this to either kernel or pulseaudio but it seems like
it most likely is a device driver issue.

00:1f.5 Multimedia audio controller: Intel Corporation 82801BA/BAM AC'97 Audio
Controller (rev 04)
	Subsystem: Dell Unknown device 010d
	Flags: bus master, medium devsel, latency 0, IRQ 17
	I/O ports at d800 [size=256]
	I/O ports at dc40 [size=64]
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0

02:09.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
	Subsystem: Creative Labs SB0090 Audigy Player
	Flags: bus master, medium devsel, latency 64, IRQ 18
	I/O ports at ece0 [size=32]
	Capabilities: [dc] Power Management version 2
	Kernel driver in use: EMU10K1_Audigy
	Kernel modules: snd-emu10k1

Full smolt: http://www.smolts.org/show?uuid=pub_78677281-8dfd-41a6-86f4-2460453c168d
Comment 22 Andrew Farris 2008-05-06 19:35:20 EDT
Antonio, do you have any other soundcard or other computer that is not using the
intel chip?  I'm wondering if your sound is also playing faster than it should
like my other bug.  If it is... that might explain the buffering issue because
gstreamer may pull in the audio at the rate it expects the data to be consumed;
my audigy card consumes it at that rate, but the intel card is going much
faster, and I think its definitely a big enough difference to cause this
buffering problem.

Can you playback any sounds so that you know for certain it is going too
quickly?  A song you're very familiar with or something like that?
Comment 23 Andrew Farris 2008-05-06 19:43:48 EDT
I just saw comment #19 so it seems your sound is slightly fast, but thats not
nearly as fast as mine is going.  Playing a song that is 6m10s long takes just
4m20s through my intel device.
Comment 24 antonio montagnani 2008-05-07 01:30:08 EDT
(In reply to comment #22)
> Antonio, do you have any other soundcard or other computer that is not using the
> intel chip?  I'm wondering if your sound is also playing faster than it should
> like my other bug.  If it is... that might explain the buffering issue because
> gstreamer may pull in the audio at the rate it expects the data to be consumed;
> my audigy card consumes it at that rate, but the intel card is going much
> faster, and I think its definitely a big enough difference to cause this
> buffering problem.
> 
> Can you playback any sounds so that you know for certain it is going too
> quickly?  A song you're very familiar with or something like that?

Unfortunately I have only one sound card.
http://www.smolts.org/show?uuid=pub_2dabf29b-bd26-4825-b7ed-ac1db85fec24

I am planning to see if an old kernel will make sound work as I had for a long
time...

rpm -iVh kernel-2.6.25-0.161.rc7.fc9.i686.rpm should add the oldest kernel that
I have found on koij (and downloaded locally) to the latest two that I have onmy
machine, shouldn't it??

Or any troubles should occur??

Comment 25 antonio montagnani 2008-05-07 02:29:59 EDT
My audio controller is:

00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R)
AC'97 Audio Controller (rev 02)
	Subsystem: ASUSTeK Computer Inc. Unknown device 8152
	Flags: bus master, medium devsel, latency 0, IRQ 17
	I/O ports at c000 [size=256]
	I/O ports at c400 [size=64]
	Memory at f9fff800 (32-bit, non-prefetchable) [size=512]
	Memory at f9fff400 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: Intel ICH
	Kernel modules: snd-intel8x0
Comment 26 Andrew Farris 2008-05-07 02:41:13 EDT
Yes, installing the kernel rpm that way should be fine.  There are older rpms in koji though that you may 
try backing up to.  I've downloaded a few that I know booted on my system (0.93.rc4, 0.40.rc1.git2, 
0.69.rc3.git1) and I'll try those to see if the fast paced intel playback and buffer issue is new since those.
Comment 27 Andrew Farris 2008-05-07 03:02:54 EDT
Antonio, you'll probably have to use rpm -i --oldpackage kernel-<version> to install the older kernel 
packages.
Comment 28 antonio montagnani 2008-05-07 03:12:34 EDT
Andrew

I have been playing music from swissradiopop with no glitch for about half an hour

Running kernel-2.6.25-0.161.rc7.fc9.i686

I will play music for all day to see if I will find any problem !!!

So the component to blame seems kernel.....
Comment 29 antonio montagnani 2008-05-07 04:19:55 EDT
Skype is running fine,
I stopped and restarted Rhythmbox.

Music has no glitch.
Comment 30 Bastien Nocera 2008-05-07 07:45:56 EDT
Great, I'll blame the kernel then :)
Comment 31 Andrew Farris 2008-05-08 14:53:45 EDT
I still have the same fast paced playback + frequent buffering, problem with the kernel-2.6.25-
0.69.rc3.git1.
Comment 32 antonio montagnani 2008-05-08 16:08:28 EDT
Andrew

will you try kernel-2.6.25-0.161.rc7.fc9.i686 that is working fine on my pc???
Comment 33 antonio montagnani 2008-05-13 12:23:20 EDT
kernel  2.6.25.3-18.fc9 installed from koij is suffering of same issues...
Comment 34 Bug Zapper 2008-05-14 05:25:31 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 35 Andrew Farris 2008-05-19 03:38:28 EDT
Antonio, I tried kernel 2.6.25-0.161.rc7.fc9 and it fails to boot on my machine;
it hangs during startup of xinitd and I haven't had a chance to workaround that
and try the audio yet.  I do still see the problem with .3-18 as you say as well.
Comment 36 antonio montagnani 2008-05-19 09:24:36 EDT
 kernel 2.6.25.4-23.fc9.i686 is suffering of same problems.

I guess that it should not difficult what changed in the audio management
between a working kernel and following releases :-) (I mean for geeks, not for
me....) 
Comment 37 Chuck Ebbert 2008-05-20 04:37:27 EDT
This is probably the same problem as bug 446192
Comment 38 antonio montagnani 2008-05-20 17:03:46 EDT
Kernel 2.6.25.4-29.fc9.i686 seems to be o.k.

I have been running it for more than half an hour and I have no glitch at all!!!!
Comment 39 Chuck Ebbert 2008-05-21 21:59:04 EDT

*** This bug has been marked as a duplicate of 446192 ***