This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 442499

Summary: No *valid* Identifier in xorg.conf
Product: [Fedora] Fedora Reporter: Akira TAGOH <tagoh>
Component: system-config-keyboardAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-15 02:28:06 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    

Description Akira TAGOH 2008-04-15 01:24:02 EDT
Description of problem:
After changing the keyboard layout with system-config-keyboard, X stopped
working because of "Parser error on line ?? of section InputDevice in file
/etc/X11/xorg.conf"

Version-Release number of selected component (if applicable):
system-config-keyboard-1.2.14-3.fc9

How reproducible:
always

Steps to Reproduce:
1.change the keyboard layout to something
2.
3.
  
Actual results:
X stopped working

Expected results:
X should works without any error regarding the keyboard stuff

Additional info:
Apparently no line feed after the comment. the problematic line looks like:

# Keyboard added by system-config-keyboard        Identifier  "Keyboard0"
Comment 1 Lubomir Kundrak 2008-04-15 02:28:06 EDT
Fix your xorg.conf by hand (sorry for this), and use newer builds of s-c-k.
Comment 2 Akira TAGOH 2008-04-15 02:58:21 EDT
Thanks for the fix. I see 1.2.15-2.fc9 is the latest version and tagged for
f9-final. but I can't see that package on even master repo for rawhide on fp.o
yet. hopefully it will be available soon. FYI.
Comment 3 Lubomir Kundrak 2008-04-15 03:34:12 EDT
Please see fedora-devel list for possible cause:
https://www.redhat.com/archives/fedora-devel-list/2008-April/msg01077.html
Comment 4 Akira TAGOH 2008-04-15 04:30:40 EDT
Ah, missed that. thanks again.