Bug 442853

Summary: Fedora 9/Anaconda Fails to detect disks
Product: [Fedora] Fedora Reporter: Jonathan Roberts <jonathan.roberts.uk>
Component: kernelAssignee: Jeff Garzik <jgarzik>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: erik-fedora, kernel-maint, peterm
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-23 16:24:16 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235706    
Attachments:
Description Flags
Output of dmesg
none
Output of lshal
none
Fedora 8 dmesg
none
dmesg of a HP DC7700, sata detection fails
none
dmesg of a HP DC7700, sata detection succeeds none

Description Jonathan Roberts 2008-04-17 04:26:34 EDT
Description of problem:

When booting from the Live CD or the boot.iso of F9 Beta (and the boot.iso of
13th April), the system fails to detect any hard disks. Obviously, Anaconda can
not install Fedora as no hard disks are present. 

Version-Release number of selected component (if applicable):

2.6.25-0.121.rc5.git4.fc9 +


How reproducible:

Every time I boot either boot.iso or Live CD. 

Steps to Reproduce:
1. Boot
2. Try to install or use hard disk
3.
  
Actual results:

No hard disks available.

Expected results:

Hard disks to be detected and the system to be installable.

Additional info:

As suggested on Fedora-test-lit, I've attached the output from lshal and dmesg
while running the Live CD. If more information is needed please feel free to let
me know and I'll do my best to get it!
Comment 1 Jonathan Roberts 2008-04-17 04:26:34 EDT
Created attachment 302723 [details]
Output of dmesg
Comment 2 Jonathan Roberts 2008-04-17 04:27:25 EDT
Created attachment 302724 [details]
Output of lshal
Comment 3 Chuck Ebbert 2008-04-18 01:03:50 EDT
What kind of hard disks are attached and what connectors are they attached to?
Comment 4 Jonathan Roberts 2008-04-18 03:00:04 EDT
It's a 160GB Serial ATA at 5400rpm...I don't know what kind of connectors are
used - it's the internal drive on my laptop (Sorry for the useless info!). Is
there someway I can check this for you? I use Fedora 8 on this system day to
day, so anything I can do on there is possible.
Comment 5 Chuck Ebbert 2008-04-18 14:39:55 EDT
Can you attach the dmesg from Fedora 8?
Comment 6 Jonathan Roberts 2008-04-18 15:45:32 EDT
Created attachment 302931 [details]
Fedora 8 dmesg

I've attached the dmesg from my F8 system...
Comment 7 Chuck Ebbert 2008-04-18 15:56:04 EDT
The Fedora 9 driver thinks the controller SATA links are down.

Fedora 9 (2.6.25-rc 12 April):
scsi2 : ata_piix
scsi3 : ata_piix
ata3: SATA max UDMA/133 cmd 0x60f8 ctl 0x611c bmdma 0x6020 irq 18
ata4: SATA max UDMA/133 cmd 0x60f0 ctl 0x6118 bmdma 0x6028 irq 18
ata3: SATA link down (SStatus 0 SControl 0)
ata4: SATA link down (SStatus 0 SControl 0)

Fedora 8 (2.6.24.4):
scsi2 : ata_piix
scsi3 : ata_piix
ata3: SATA max UDMA/133 cmd 0x60f8 ctl 0x611c bmdma 0x6020 irq 20
ata4: SATA max UDMA/133 cmd 0x60f0 ctl 0x6118 bmdma 0x6028 irq 20
ata3.00: ATA-8: Hitachi HTS542516K9SA00, BBCAC3GP, max UDMA/133
ata3.00: 312581808 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata3.00: configured for UDMA/133
scsi 2:0:0:0: Direct-Access     ATA      Hitachi HTS54251 BBCA PQ: 0 ANSI: 5
Comment 8 Erik van Pienbroek 2008-04-21 18:27:02 EDT
I'm also encountering this problem on the computers we have at our university.
These are HP DC7700's.

When trying to install rawhide (using PXE boot and installation from a download
mirror), anaconda fails to detect the SATA harddrive. In the dmesg I'm also
seeing the 'SATA link down' messages but with different values for the SStatus
and SControl.

However, sometimes the SATA harddrive is detected normally. Most of the time I
need to switch desktops (ALT+F3) and move the mouse a bit right before the SATA
initialisation is started to make the SATA harddrive detection succeed.

I'll try to generate a dmesg for both the working and non-working situation
tomorrow.
Comment 9 Erik van Pienbroek 2008-04-22 07:12:29 EDT
Created attachment 303295 [details]
dmesg of a HP DC7700, sata detection fails

Relevant messages:
ata1: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0x10e0 irq 14
ata2: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0x10e8 irq 15
ata1: SATA link down (SStatus 621 SControl 300)
ata2: SATA link down (SStatus 611 SControl 300)
Comment 10 Erik van Pienbroek 2008-04-22 08:17:08 EDT
With the latest anaconda (available on your local mirror) I can't even get the
SATA drive to detect anymore..even with the workaround I described.

With kernel 2.6.25-0.218.rc8 my installed Fedora 9 system boots fine (without
any workarounds), but with kernel 2.6.25-1 it doesn't boot any more: unable to
find the root partition...

Another thing I noticed with kernel 2.6.25-0.218.rc8 was that the DVD drive
(which is also connected by SATA) isn't detected..
Comment 11 Erik van Pienbroek 2008-04-22 12:26:16 EDT
Created attachment 303337 [details]
dmesg of a HP DC7700, sata detection succeeds

This dmesg is from the preview release of F9 and sata detection succeeds with
this one
Comment 12 Erik van Pienbroek 2008-04-23 07:26:55 EDT
I think this bug can be considered a duplicate of bug 436099.
With kernel 2.6.25-6 the SATA problems are solved for me. I'm now waiting for a
new anaconda build with this kernel, but I don't expect problems with it anymore.
Comment 13 Chuck Ebbert 2008-04-23 16:24:16 EDT

*** This bug has been marked as a duplicate of 436099 ***