Bug 443518

Summary: Lots of issues with galeon in F9
Product: [Fedora] Fedora Reporter: Martin Ebourne <fedora>
Component: galeonAssignee: Denis Leroy <denis>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: alexl, ian.laurie, ismael, jan.kratochvil, kas, ondrejj, yaneti
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-07 05:49:42 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 449806    
Bug Blocks:    

Description Martin Ebourne 2008-04-21 18:44:20 EDT
Description of problem:
The new xulrunner galeon in the Fedora 9 preview release has broken lots of things.

Version-Release number of selected component (if applicable):
galeon-2.0.5-1.fc9.x86_64
xulrunner-1.9-0.55.beta5.fc9.x86_64

How reproducible:
Every time

Things that are broken:

=== 1 ===

Printing is completely broken. Any attempt to print (toolbar or menu) gives this
error box:
There was a problem printing. No printers could be found.
Check whether the "XPSERVERLIST" environment variable contains at least one
valid Xprint server. For further information see http://xprint.mozdev.org or
http://www.mozilla.org/projects/xprint/.

Other apps (eg. epiphany work fine).

=== 2 ===

Java script isn't working despite being enabled

=== 3 ===

Accessing web sites with self signed or other CA signed certificates fails. eg.
Secure Connection Failed

ebourne.me.uk uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is not trusted.

(Error code: sec_error_untrusted_issuer)

If I select the add an exception link I get a message telling me to add an
exception in the advanced settings.

I visit Edit->Preferences->Privacy->Manage Certificates->Servers->Add exception.
I then have to reenter the web address which gets the certificate. Clicking on
Confirm Security Exception does nothing though, the dialogue box stays and no
exception is registered.

=== 4 ===

The fonts don't seem to be sizing properly, I need to investigate this one to
confirm.

Additional info:
All in, galeon is unfortunately quite unusable in this release.
Comment 1 Denis Leroy 2008-04-22 15:53:48 EDT
Yes I know. Upstream is dormant and reluctant to make efforts to port to the
still unstable xulrunner API.

Patches more than welcome.

Comment 2 Alex Lancaster 2008-05-12 18:20:35 EDT
Another issue:

Password/password site saving doesn't work: all password info in "Personal Data"
is blank, see upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=531953

Comment 3 Bug Zapper 2008-05-14 05:54:08 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Ismael Olea 2008-07-03 07:57:07 EDT
*** Bug 452527 has been marked as a duplicate of this bug. ***
Comment 5 Ismael Olea 2008-07-03 08:08:34 EDT
If xulrunner is so feature broken, could be possible to compile using the
firefox code instead?
Comment 6 Denis Leroy 2008-07-03 12:03:05 EDT
It's not so much xulrunner that's broken. It's just unstable. The problem is
more that galeon needs a bunch of patches to behave better with xulrunner (like
epiphany), but upstream is dormant while xulrunner is not stabilized, and there
are very few people in the Fedora community that are comfortable with
Mozilla/xullrunner code to actually fix galeon... :-(
Comment 7 Jan "Yenya" Kasprzak 2008-07-04 04:30:53 EDT
Well, the solution for Fedora should probably be "provide a firefox-compat"
package, and link Galeon against it.
Comment 8 Alex Lancaster 2008-07-04 04:57:56 EDT
(In reply to comment #7)
> Well, the solution for Fedora should probably be "provide a firefox-compat"
> package, and link Galeon against it.

Probably not going to happen as the consensus for introducing compat packages is
described here:

https://fedoraproject.org/wiki/JeremyKatz/DraftCompatPackages

and I believe that Chris Aillon (one of the xulrunner/firefox maintainers) has
stated at some point that he was against (or at least not for) such a
firefox-compat package.

I'm afraid that we galeon users probably have to bite the bullet and abandon
galeon for F-9 and later as it is more or less dormant upstream and unless
somebody does a lot of work to bring it up to xulrunner snuff, it's likely to
bitrot.  The options as I see them are:

1. try to coax the epiphany devs to reintroduce various Galeon features which
was actually proposed by the galeon maintainers when full throated development
on galeon stopped about 2 years ago.  The galeon developers made a good start by
listing the requirements here http://live.gnome.org/Epiphany/GaleonIssues and
there is some buy-in from epiphany developers I believe, but not much progress
seems to have been made on that list when I last tested epiphany on F-9 as there
are still many features missing (e.g. Full Cookie/Password/Image/Popup control
in Personal Data Manager)

2. switch to firefox

I choose option (2) as the path of least resistance for F-9 and at least
firefox-3 is a bit better integrated with GNOME at least than earlier firefoxes.
Comment 9 Denis Leroy 2008-07-08 04:05:05 EDT
Not much improvement, but here's 2.0.6:

http://www.poolshark.org/src/galeon-2.0.6-1.fc9.src.rpm

Comment 10 Matěj Cepl 2008-07-22 06:07:33 EDT
Printing is bug 449806, so it shouldn't be handled here. What else remains with
the current version of galeon?
Comment 11 Denis Leroy 2008-07-23 04:09:31 EDT
Matej, authentication and personal data saving.
Comment 12 Ismael Olea 2008-07-29 04:46:35 EDT
(In reply to comment #10)
> Printing is bug 449806, so it shouldn't be handled here. What else remains with
> the current version of galeon?

Management of invalid SSL certs.
Comment 13 Matěj Cepl 2008-09-12 11:14:22 EDT
Yeap, from the original list points 1 and 3 are still there live and kicking. I don't see any issues with fonts and galeon-2.0.5-2.fc9.i386 and xulrunner-1.9.0.1-1.fc9.i386, and although I haven't made extensive testing both gmail.com and internal Red Hat mailweb site (which runs Zimbra) seems to work reasonably well (I didn't make extensive testing though).
Comment 14 Fedora Update System 2008-09-27 13:23:44 EDT
galeon-2.0.7-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/galeon-2.0.7-1.fc9
Comment 15 Jan ONDREJ 2008-09-27 15:13:10 EDT
1 (printing) and 3 (ssl) is still broken.

Password saving and http auth looks to be OK.

Most of this bug is still not fixed.
Comment 16 Fedora Update System 2008-10-01 02:38:56 EDT
galeon-2.0.7-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update galeon'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8478
Comment 17 Jan "Yenya" Kasprzak 2008-10-03 05:59:22 EDT
I can confirm that 1 (printing) is still broken as it was in the original report.

Basic auth works (thanks!), but adding SSL cert exception is a bit hard.

I may add a new minor problem (4):

On startup on a freshly installed (and yum-updated) machine it pops-up a dialog box saying "myportal:" is not a registered protocol.

- should I open a new bug for it?
Comment 18 Ismael Olea 2008-10-04 07:24:09 EDT
Another bug:

When saving an url into a file stills appears the option to save content too. Without seting it on it saves the content.

For me, is a nice feature to save everything so, would seem fine to remove the save content option.
Comment 19 Denis Leroy 2008-10-04 08:57:00 EDT
Yes that's 410831.

I'm welcoming patches for the various problems :-) Upstream is not actively fixing this, although they are accepting patches from the various distro maintainers and releasing them appropriately.
Comment 20 Denis Leroy 2008-10-06 19:41:43 EDT
I worked on a couple of patches: printing support and default font setting. Testing requested :-)

http://www.poolshark.org/src/galeon-2.0.7-2.fc10.src.rpm
Comment 21 Fedora Update System 2008-10-07 05:49:28 EDT
galeon-2.0.7-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Denis Leroy 2008-10-07 05:58:14 EDT
Well it's really 2.0.7-2 that should close this bug, but I'll leave it closed. Let's open new bugs for the specific problems that are remaining.
Comment 23 Jan ONDREJ 2008-10-07 06:00:35 EDT
Thank you for patches. Printing works for me now.

Can you fix also SSL problems? It's a more important problem for me.
Comment 24 Jan "Yenya" Kasprzak 2008-10-07 10:11:41 EDT
Printing works for me (2.0.7-2.fc10 rebuild on F9), thanks!
The myportal: problem (comment #17) still persists.

I really think 2.0.7-2 should be pushed also to F9 repositories.