Bug 443765

Summary: im-chooser shows Input Method enabled when it is not
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: im-chooserAssignee: Akira TAGOH <tagoh>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: eng-i18n-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.99.6-3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-30 14:36:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235706    

Description Jens Petersen 2008-04-23 03:55:19 EDT
Description of problem:
If one runs im-chooser in a new desktop session with scim running
(eg in en_US.UTF-8), it shows the Input method feature is enabled
even though it is actually not.

Version-Release number of selected component (if applicable):
im-chooser-0.99.5-3.fc9

How reproducible:
everytime

Steps to Reproduce:
1. boot fresh rawhide install or Preview Live
2. Login under English
3. run im-chooser
  
Actual results:
3. says IM enabled though it is not

Expected results:
3. should show IM disabled
Comment 1 Akira TAGOH 2008-04-25 10:18:36 EDT
Fixed in 0.99.6-2
Comment 2 Jens Petersen 2008-04-28 02:50:23 EDT
I tried 0.99.6-2.fc9 and it still seems to happen for me.
Comment 3 Akira TAGOH 2008-04-28 04:53:07 EDT
It works for me. please make sure:

1. you don't have $HOME/.xinputrc symlinking to any IM
2. no errors with imsettings-list say
3. no "*" on any IMs with imsettings-list.

In this fix, imsettings-list should shows you "*" if IM /is/ running. otherwise
"-" is marked for default IM regardless of which locale you are now on. i.e. "*"
 means any IM is currently running and this results a check box on im-chooser is
turned on.
Comment 4 Jens Petersen 2008-04-28 21:00:22 EDT
> 1. you don't have $HOME/.xinputrc symlinking to any IM

No .xinputrc

> 2. no errors with imsettings-list say

No errors output.

> 3. no "*" on any IMs with imsettings-list.

$ imsettings-list
* 1: SCIM (recommended)

> In this fix, imsettings-list should shows you "*" if IM /is/ running. otherwise
> "-" is marked for default IM regardless of which locale you are now on. i.e. "*"
>  means any IM is currently running and this results a check box on im-chooser is
> turned on.

There is no scim processes running:

$ ps ax | grep scim | grep -v grep
$
Comment 5 Akira TAGOH 2008-04-28 21:55:00 EDT
Okay, do you have /tmp/scim_conf:xim*?
Comment 6 Jens Petersen 2008-04-28 22:18:45 EDT
Yes
Comment 7 Akira TAGOH 2008-04-28 22:23:01 EDT
After removing them, it works as expected right?
Comment 8 Jens Petersen 2008-04-28 23:22:49 EDT
I had two: one for user and one for root.

After removing the one for user it works fine for user.
Comment 9 Jens Petersen 2008-04-28 23:24:03 EDT
(Explicitly /tmp/scim_conf:xim:{0.0-petersen,1.0-root}.)
Comment 10 Akira TAGOH 2008-04-29 00:06:59 EDT
Should be fixed in 0.99.6-3
Comment 11 Jens Petersen 2008-04-29 00:26:01 EDT
Thanks - looks good now. :-)
Comment 12 Bill Nottingham 2008-04-30 14:36:31 EDT
Closing due to confirmation of fix.