Bug 443982

Summary: Qemu SELinux messages
Product: [Fedora] Fedora Reporter: Martin Jürgens <ma>
Component: qemuAssignee: David Woodhouse <dwmw2>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: hdegoede, markmc, poelstra, virt-maint, walovaton
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-20 09:57:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Description Flags
selinux alerts i encounter none

Description Martin Jürgens 2008-04-24 14:10:50 UTC
Description of problem:
I'm using virt-manager to start create Qemu machines. When I finish to create
them / start them i get lots of Selinux messages. I already tried to relabel the
files stated there, but it does not fix the issues.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create qemu virtual machine using virt-manager
Actual results:
SELinux errors

Comment 1 Martin Jürgens 2008-04-24 14:10:50 UTC
Created attachment 303633 [details]
selinux alerts i encounter

Comment 2 John Poelstra 2008-04-24 22:17:58 UTC
David-is this really a qemu issue or should this be reassigned to

Comment 3 Bug Zapper 2008-05-14 10:04:53 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:

Comment 4 Brennan Ashton 2008-06-08 03:05:32 UTC
Assignee, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

Comment 5 Daniel Berrange 2008-06-11 10:05:58 UTC
Where did you locate your disk images ?  

As of Fedora 9, if you are running with SELinux enabled & enforcing, disk images
need to be located under /var/lib/libvirt/images/

Comment 6 William Lovaton 2008-12-27 21:41:33 UTC
(In reply to comment #5)
> Where did you locate your disk images ?  
> As of Fedora 9, if you are running with SELinux enabled & enforcing, disk images
> need to be located under /var/lib/libvirt/images/

I think this might be the problem.  I tried installing WinXP from the CD under qemu-kvm and it worked fine.  Then I repeated the installation copying the iso to my home directory and virt-manager failed starting the virtual machine because SELinux forbids access to the iso image.  I tried changing the context of the iso image as suggested by the troubleshooter but it didn't work.  I had to change SELinux to permissive mode temporarily while doing the installation.

Comment 7 Mark McLoughlin 2009-04-20 09:57:24 UTC
Missing info from reporter, closing

Comment 8 William Lovaton 2009-04-20 12:42:58 UTC
Mmmm, I promise I'll try this on my updated Fedora 10 laptop and post a comment here.

But, why images need to be located in /var/lib/libvirt/images/? can't a mortal user use his home directory? I think Qemu/KVM should work without root privileges.