This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 444678

Summary: Needs to require python
Product: [Fedora] Fedora Reporter: Orion Poplawski <orion>
Component: sconsAssignee: Gérard Milmeister <gemi>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-06 14:42:46 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235705    

Description Orion Poplawski 2008-04-29 18:19:44 EDT
Description of problem:

scons needs python to run yet does not require python.

$ rpm -q --requires scons
/usr/bin/env
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Hopefully this could get fixed for F9.

Version-Release number of selected component (if applicable):
scons-0.98.0-1.fc9.noarch
Comment 1 Gérard Milmeister 2008-04-29 18:54:09 EDT
Why doesn't the automatic generation of Python requirements as per
http://fedoraproject.org/wiki/Packaging/Python
work?
Comment 2 Orion Poplawski 2008-05-08 12:40:57 EDT
Apparently because /usr/bin/scons doesn't have "#!/usr/bin/python" but
"#!/usr/bin/env python".
Comment 3 Bug Zapper 2008-05-14 06:24:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Gérard Milmeister 2008-06-06 14:42:46 EDT
fixed shebang line