Bug 444921

Summary: preupgrade doesn't handle /boot being out of space
Product: [Fedora] Fedora Reporter: nathan r. hruby <nhruby>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideCC: katzj, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.9.3-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-02 11:59:13 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description nathan r. hruby 2008-05-01 18:32:59 EDT
Description of problem:
preupgrade fails to compute required space on /boot.  Should there be
insufficient space, it fails to download the image (in my case stage2) and
tosses up an error, but still changes grub and prompts the user to reboot as if
it were successful.

Version-Release number of selected component (if applicable):
preupgrade-0.9.2-1.fc8

How reproducible:
Every time

Steps to Reproduce:
1. make a small /boot (of about 100MB) on a f8 system
2. run preupgrade 

  
Actual results:
preupgrade fails to download stage2 image file (minstg2.img ~60MB) due to space
constraints but still changes grub.conf and  prompts user to reboot.

Expected results:
preupgrade would fail to run due to lack of space on /boot, or at least not
change grub.conf

Additional info:
Doesn't anaconda's "autopartition my disk" feature default to 100MB /boot?
Comment 1 Will Woods 2008-05-02 11:59:13 EDT
If you *do* have insufficient space in /boot, we just download stage2 after you
reboot instead. The error message now says this pretty clearly:

"Not enough space in /boot to cache stage2.img.
It will be downloaded once the installer starts."

Once you reboot it fetches stage2.img and the install continues normally.

This only happens if you have an older system or you intentionally create a
small /boot. F8 and later default to 200MB /boot for exactly this purpose.
Comment 2 nathan r. hruby 2008-05-02 12:19:45 EDT
Yeah, I kinda figured out the 'it grabs stage2 later' after a few less than
useful attempts at the reboot and looking at the grub entries.  The updated
error message should be enough to mollify the ultra-stupid such as myself, thanks!

Presently I'm getting at error at reboot about my groups info being wrong due to
a bad composition regardless of what mirror I try or blowing away all the stuff
in /var/cache/yum/anaconda-upgrade.  skvidal looks to have built an 0.9.3 this
morning, so I'll try that and open another bug if I have trouble or just hop on
#fedora-devel.

Or I could just ramble away in this ticket forever....
Comment 3 Will Woods 2008-05-02 12:33:11 EDT
See bug 444915: Unable to read group information with preupgrade