Bug 446123

Summary: LTC:5.3:201635:Sync watchdog package to latest available upstream
Product: Red Hat Enterprise Linux 5 Reporter: IBM Bug Proxy <bugproxy>
Component: watchdogAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 5.3CC: cward, jjarvis, jscotka, rjones, rlerch, sghosh, syeghiay
Target Milestone: betaKeywords: FutureFeature, OtherQA, Rebase
Target Release: 5.4   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The watchdog package provides a user-space application which can be configured to provide updates to a hardware or software watchdog timer via the Linux kernel's watchdog interface. Enhancements in this package include: * added 'another-chance' repair script * added wd_keepalive manpage * wd_keepalive honors the config file option * wd_keepalive will not start without a watchdog device * rare segfault on shutdown fixed * multiple code cleanups to improve error reporting Users who wish to use this enhanced functionality should install this package.
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-09-02 06:04:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 445204, 483784    

Description IBM Bug Proxy 2008-05-12 17:08:33 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-05-12 16:50 EDT
1. Feature Id:	[201635]
Feature Name:	Sync watchdog package to latest available upstream
Sponsor:	xSeries
Category:	xSeries
Request Type:	Package - Update Version

2. Short Description
The watchdog package included in RHEL5 has been updated upstream from version 5.3.1 (currently in
RHEL5.1/RHEL5.2) to version 5.4. Updates include: Added 'another-chance' repair script written by
Erik Rossen, Applied some changes to Red Hat init script, Added sysconf script for Red Hat, Made
wd_keepalive honor config file option, Added wd_keealive manpage, Made wd_keepalive not start
without a watchdog device, Fixed some typos in watchdog manpage. We are requesting that the watchdog
RPM in RHEL5.3 be refreshed to version 5.4. http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/

3. Business Case
Provides updated watchdog software in-distro, so customers don't have to download this directly from
Web. One of the most useful updates is the addition of a man page, which greatly reduces the
potential for mis-configuration, etc.


4. Sponsor Priority	2
IBM Confidential:	no
Code Contribution:	no
Upstream Acceptance:	Accepted
Component Version Target:	watchdog package 5.4 or later
Performance Assistance:	

5. PM Contact:	Monte Knutson, mknutson@us.ibm.com, 877-894-1495

6. Technical contact(s):
Kevin Stansell, kstansel@us.ibm.com
Chris McDermott, mcdermoc@us.ibm.com

7. LTC Manager: Deneen T. Dock, deneen@us.ibm.com
Comment 2 IBM Bug Proxy 2008-10-02 18:46:09 EDT
Red Hat, there's some internal confusion on our end. Can you please tell us whether this feature request was accepted for RHEL5.3? Will the watchdog package be updated? Thanks.
Comment 4 IBM Bug Proxy 2008-11-03 11:21:15 EST
It's been a month and no feedback from Red Hat. Assuming this is deferred to RHEL5.4.
Comment 6 John Jarvis 2008-12-09 14:34:59 EST
*** Bug 475348 has been marked as a duplicate of this bug. ***
Comment 9 IBM Bug Proxy 2009-01-22 17:11:12 EST
Emily J. Ratliff <ratliff@austin.ibm.com> -
1. Feature Overview:
Feature Id:	[201635]
a. Name of Feature:	Sync watchdog package to latest available upstream
b. Feature Description
Erik Rossen, Applied some changes to RedHat init script, Added sysconf script for RedHat, Made
RPM in RHEL5.4 be refreshed to version 5.4. http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/

2. Feature Details:
Architectures:
x86
x86_64

Arch Specificity: Purely Common Code
Affects Kernel Modules: Yes
Delivery Mechanism:
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
g. Component Version Target:	watchdog package 5.4 or later


4. Primary contact at Red Hat:
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Monte Knutson, mknutson@us.ibm.com, 877-894-1495

Technical contact(s):

IBM Manager:
Deneen T. Dock, deneen@us.ibm.com
*** This bug has been marked as a duplicate of 446123 ***
Comment 11 John Jarvis 2009-03-09 15:29:29 EDT
IBM is signed up to test and provide feedback.
Comment 12 Richard W.M. Jones 2009-03-09 18:01:00 EDT
Can I just point out that the latest upstream is watchdog-5.5
(http://sourceforge.net/projects/watchdog).  It was only released
a couple of weeks ago.  Can I clarify whether IBM would like to
go with this even newer release?
Comment 13 IBM Bug Proxy 2009-03-09 20:50:34 EDT
(In reply to comment #11)
> Can I just point out that the latest upstream is watchdog-5.5
> (http://sourceforge.net/projects/watchdog).  It was only released
> a couple of weeks ago.  Can I clarify whether IBM would like to
> go with this even newer release?

Hi,

Thank you for asking about this new release.  :-)    The code changes between 5.4 and 5.5 are relatively small but include fixes for some issues (such as the segfault described in Debian bug #514295) that might be of help so some folks using the package.  So, yes, please do pull in the latest package:  watchdog-5.5.

Thanks again.
Comment 18 Richard W.M. Jones 2009-03-18 05:00:23 EDT
Just to keep everyone updated on this, Lon has been internally
testing the watchdog git release, and we are expecting that
watchdog 5.6 is going to come out Real Soon Now.
Comment 20 John Jarvis 2009-03-26 08:53:21 EDT
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 21 IBM Bug Proxy 2009-04-02 22:50:45 EDT
------- Comment From hebertc@us.ibm.com 2009-04-02 22:48 EDT-------
(In reply to comment #14)
> This enhancement request was evaluated by the full Red Hat Enterprise Linux
> team for inclusion in a Red Hat Enterprise Linux minor release.   As a
> result of this evaluation, Red Hat has tentatively approved inclusion of
> this feature in the next Red Hat Enterprise Linux Update minor release.
> While it is a goal to include this enhancement in the next minor release
> of Red Hat Enterprise Linux, the enhancement is not yet committed for
> inclusion in the next minor release pending the next phase of actual
> code integration and successful Red Hat and partner testing.
>

Hi,

I tested the following packages on a 32- and 64- bit x3950 and a 64-bit x3850:

i386/watchdog-5.6-1.el5.i386.rpm
i386/watchdog-debuginfo-5.6-1.el5.i386.rpm
x86_64/watchdog-5.6-1.el5.x86_64.rpm
x86_64/watchdog-debuginfo-5.6-1.el5.x86_64.rpm

No issues were found with package installation or with either the watchdog daemon or the wd_keepalive daemon when tested with the IPMI Hardware Watchdog Timer and the ipmi_watchdog driver.  Both daemons prevented the Timer from firing and also shut down the timer gracefully using either the startup script or the kill -s SIGTERM methods.

Howver, the watchdog.debug and wd_keepalive.debug executables in both the 64-bit and the 32-bit debug packages would not run:

[root@elm3a43 sbin]# file *
watchdog.debug:         ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped
wd_keepalive.debug:     ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, not stripped
# ./watchdog.debug
-bash: ./watchdog.debug: ?: bad ELF interpreter: No such file or directory
[root@elm3a43 sbin]# ./wd_keepalive.debug
-bash: ./wd_keepalive.debug: ?: bad ELF interpreter: No such file or directory

Maybe they weren't intended to be run this way?

Please let me know if you need anything further from me on this.

Thank you.

------- Comment From hebertc@us.ibm.com 2009-04-02 22:49 EDT-------
(In reply to comment #15)

> I tested the following packages on a 32- and 64- bit x3950 and a 64-bit x3850:
>
>  i386/watchdog-5.6-1.el5.i386.rpm
> i386/watchdog-debuginfo-5.6-1.el5.i386.rpm
> x86_64/watchdog-5.6-1.el5.x86_64.rpm
> x86_64/watchdog-debuginfo-5.6-1.el5.x86_64.rpm
>

Sorry, I should have mentioned that I did all my testing on RHEL5.3 bits:

]# uname -a
Linux elm3a43 2.6.18-128.el5PAE #1 SMP Wed Dec 17 12:02:33 EST 2008 i686 i686 i386 GNU/Linux

# uname -a
Linux elm3a99.beaverton.ibm.com 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
Comment 25 Richard W.M. Jones 2009-04-24 11:28:19 EDT
In reply to comment 21:

Sorry, this fell through the cracks in my to-do list to reply
to this.

The -debuginfo package and the watchdog-debug file isn't
meant to be run directly.  When (if) you do 'gdb watchdog',
gdb will automatically find the watchdog-debug file and load
the debug symbols from it.

So basically you don't need to worry about the debuginfo
package unless you're trying to run watchdog under gdb.
Comment 26 Richard W.M. Jones 2009-04-24 11:29:02 EDT
I mean 'watchdog.debug' not 'watchdog-debug'.
Comment 28 Richard W.M. Jones 2009-04-27 10:16:28 EDT
rebase committed in watchdog-5_6-1_el5
Comment 29 IBM Bug Proxy 2009-04-27 12:40:34 EDT
------- Comment From sglass@us.ibm.com 2009-04-27 12:38 EDT-------
Since this in now in RH cvs tree, moving to Accepted state
Comment 31 Chris Ward 2009-06-14 19:15:15 EDT
~~ Attention Partners RHEL 5.4 Partner Alpha Released! ~~

RHEL 5.4 Partner Alpha has been released on partners.redhat.com. There should
be a fix present that addresses this particular request. Please test and report back your results here, at your earliest convenience. Our Public Beta release is just around the corner!

If you encounter any issues, please set the bug back to the ASSIGNED state and
describe the issues you encountered. If you have verified the request functions as expected, please set your Partner ID in the Partner field above to indicate successful test results. Do not flip the bug status to VERIFIED. Further questions can be directed to your Red Hat Partner Manager. Thanks!
Comment 34 Richard W.M. Jones 2009-06-26 10:41:21 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The watchdog package provides a user-space application which can be
configured to provide updates to a hardware or software watchdog timer via
the Linux kernel's watchdog interface.

Enhancements in this package include:
* added 'another-chance' repair script
* added wd_keepalive manpage
* wd_keepalive honors the config file option
* wd_keepalive will not start without a watchdog device
* rare segfault on shutdown fixed
* multiple code cleanups to improve error reporting

Users who wish to use this enhanced functionality should install this package.
Comment 35 Chris Ward 2009-07-03 14:02:56 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 36 IBM Bug Proxy 2009-07-08 16:10:45 EDT
------- Comment From bigmach@us.ibm.com 2009-07-08 16:04 EDT-------
I have tested the watchdog daemon from the watchdog-5.6-1.el5 package on an LS42 blade running 64-bit RHEL5.4 Beta (kernel 2.6.18-155.el5) and it functioned as expected.
Comment 37 IBM Bug Proxy 2009-07-08 16:11:15 EDT
------- Comment From bigmach@us.ibm.com 2009-07-08 16:03 EDT-------
(In reply to comment #23)
Comment 39 errata-xmlrpc 2009-09-02 06:04:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1327.html
Comment 40 IBM Bug Proxy 2011-02-22 05:04:19 EST
------- Comment From prem.karat@linux.vnet.ibm.com 2011-02-22 04:56 EDT-------
(In reply to comment #6)
> I have tested the watchdog daemon from the watchdog-5.6-1.el5 package on an
> LS42 blade running 64-bit RHEL5.4 Beta (kernel 2.6.18-155.el5) and it
> functioned as expected.

***Reviewed as a part of clean up activity********

Closing this one out as per the last comment

Cheers,
Prem
Comment 41 IBM Bug Proxy 2011-02-22 05:14:22 EST
------- Comment From prem.karat@linux.vnet.ibm.com 2011-02-22 05:05 EDT-------
(In reply to comment #25)
> An advisory has been issued which should help the problem
> described in this bug report. This report is therefore being
> closed with a resolution of ERRATA. For more information
> on therefore solution and/or where to find the updated files,
> please follow the link below. You may reopen this bug report
> if the solution does not work for you.
>
> http://rhn.redhat.com/errata/RHEA-2009-1327.html