Bug 446371

Summary: Anaconda doesn't detect old network configuration, stalls at "Retrying package download"
Product: [Fedora] Fedora Reporter: Zoltan Boszormenyi <zboszor>
Component: preupgradeAssignee: Seth Vidal <skvidal>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-21 16:46:02 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Zoltan Boszormenyi 2008-05-14 06:49:12 EDT
Description of problem:

I tried preupgrade to upgrade from Fedora 8 to 9, it downloaded packages about
6.2 GB in total. Then I rebooted into Anaconda to perform upgrade. Anaconda
finds the old partitions correctly but doesn't activate the network connections.
Maybe it tries to but only DHCP over plain ethernet. I have an ADSL connection
via an ADSL modem not a router. pppoe configuration is not pulled from the
installed Fedora 8. Anaconda stalls at "Retrying package download". I killed it
after about a minute.

Version-Release number of selected component (if applicable):


How reproducible:

3 out of 3 tries.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Cannot perform upgrade

Expected results:

Anaconda should detect the network configuration and start it if network
activity is expected.

Additional info:
Comment 1 Chris Lumens 2008-05-15 00:44:53 EDT
Which package is it trying to download, and what version of preupgrade did you use?
Comment 2 Zoltan Boszormenyi 2008-05-15 01:19:32 EDT
The anaconda dialog didn't tell the package name, only "Retrying package download".
I started with preupgrade-0.9.3-1 then I killed it when 0.9.3-2 came out (0.9.3
was already downloading packages) and upgraded to the new one. I restarted with
the new one and it continued downloading packages. Then it hung at the last
download phase so I killed it again. This probles was solved by 0.9.3-3 that
finished the procedure and offered the "reboot now" button.
Comment 3 David A. Wheeler 2008-05-16 14:45:15 EDT
It doesn't _stall_ for me, but 0.9.3-3 does not retain the existing network
configuration and makes me re-enter this information (which is an annoyance).

Thus, when rebooting, I must tell it that I have IPv4, that I don't have IPv6,
and must give my static IP address, mask, gateway address, and DNS hosts. 
PreUpgrade should be able to get all that info from the current config.  Perhaps
PreUpgrade could add the network info to the grub.conf file?!?

Comment 4 Will Woods 2008-05-16 15:30:34 EDT
Not really - anaconda can't set up every possible network configuration that you
might been using on your system (e.g. wireless with WPA, VPN, etc)

The *proper* solution is to make sure we download all the right packages first
so you don't *need* the network.
Comment 5 Zoltan Boszormenyi 2008-05-18 18:52:32 EDT
I re-tried with 0.9.3-3 from scratch by deleting /var/cache/yum/anaconda-upgrade
and the old preupgrade GRUB entry but the only change was that in the new GRUB
entry the method= parameter had a different mirror. It still stalls at starting
upgrade after discovering package dependencies, giving the same dialog with
empty title bar and the message is "Retrying package download". Ctrl-Alt-F2 and
"ip addr" shows no established network.
Comment 6 Rafael Messias Martins 2008-05-23 17:30:58 EDT
(In reply to comment #4)
> Not really - anaconda can't set up every possible network configuration that 
you
> might been using on your system (e.g. wireless with WPA, VPN, etc)
> The *proper* solution is to make sure we download all the right packages first
> so you don't *need* the network.

I believe this happens because of new packages installed *after* preupgrade 
finished download everything. I left the "reboot now" window hanging around and 
kept on yumming new stuff... had to re-enter my network parameters on anaconda.
Comment 7 Rafael Messias Martins 2008-05-23 17:32:40 EDT
Maybe the best solution would be to leave the new packages as they are, if 
anaconda can't reach the internet... upgrade only the ones preupgrade 
downloaded.
Comment 8 Will Woods 2008-05-23 17:47:31 EDT
Sure, that's a good idea, but we can't change the behavior of F9 anaconda,
because it's frozen as part of the release. So that's not going to work.

There's a workaround for missing kernel packages on i386 installs, but 64-bit
machines (x86_64/ppc64) will end up with missing packages because of differences
between F8 yum and anaconda.

I'm not sure we can fix that problem for F8->F9. We might have to wait until
F10. Luckily F10Alpha is only 8 weeks away or so.
Comment 9 Will Woods 2008-10-21 16:46:02 EDT
This is fixed in Fedora 10's anaconda + preupgrade 0.9.8.