Bug 446598

Summary: dhclient.conf not working as expected
Product: [Fedora] Fedora Reporter: Rohan Dhruva <rohandhruva>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: dcbw, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-25 16:13:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
My dhclient.conf none

Description Rohan Dhruva 2008-05-15 09:53:37 UTC
Description of problem:
As I had said in this bug - https://bugzilla.redhat.com/show_bug.cgi?id=398351 -
I need to set a custom DNS for my machine. In resolv.conf, I need to add the
line "nameserver". In fedora 8, I did that by creating an appropriate
dhclient.conf file. Using the same file in Fedora 9 doesn't work - the
line doesn't appear in resolv.conf, only I'm attaching my
dhclient.conf file.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create the file /etc/dhclient.conf (attached)
2. Reboot
3. Check, /etc/resolv.conf still not updated with new DNS entries
Actual results:
/etc/resolv.conf is not updated with the proper DNS entry.

Expected results:
/etc/resolv.conf should have first line as 


Additional info:
The attached file worked perfectly in Fedora 8.

Comment 1 Rohan Dhruva 2008-05-15 09:53:37 UTC
Created attachment 305459 [details]
My dhclient.conf

Comment 2 Dan Williams 2009-02-14 21:27:23 UTC
Can you try moving your options to a dhclient-eth0.conf using the name of the interface?  NM will honor interface-specific dhclient config files and merge them into the config it actually uses with dhclient.

Comment 3 Rohan Dhruva 2009-02-25 09:10:39 UTC
Thank you very much, that works as expected :)
Can you please help me close this bug?

Comment 4 Dan Williams 2009-02-25 16:13:30 UTC
Sure, thanks for the report.