Bug 446824

Summary: preupgrade does not download libsoup22 which causes problem at installation time
Product: [Fedora] Fedora Reporter: Shailesh Narvekar <slashn>
Component: preupgradeAssignee: Will Woods <wwoods>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://shailesh-techtravels.blogspot.com/2008/05/sulphurised-fedora-9-preupgrade.html
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-26 01:12:54 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Shailesh Narvekar 2008-05-16 06:36:08 EDT
Description of problem:
preupgrade successfully downloads all the required packages, but on rebooting
tries to connect to the internet with a message 'Retrying download of packages'.
However this step too fails(I am not sure if this was a problem with my internet
settings or just a genuine problem), but the bug here is there should be no need
to connect to the internet.

It reports that the libsoup22-2.2.105-2.fc9.i386.rpm package is corrupted or
missing. I downloaded this package manually and placed in yum
cache(/var/cache/yum/anaconda-upgrade/packages) and it worked fine.

So I guess the bug is with preupgrades figuring out which packages should be
downloaded.

Am assigning a severity of low as workaround exists, but was potentially a show
stopper for me.



Version-Release number of selected component (if applicable):
preupgrade-0.9.3-3

How reproducible:
Could do the installation only once.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Anaconda tries to connect to the internet to download packages, when this should
already have been done in the first step. Even then, it fails to download the
package.

Expected results:
Installation should carry on without connecting to internet to download further
packages.

Additional info:
Comment 1 Will Woods 2008-05-16 10:49:27 EDT
The problem is that anaconda and preupgrade differ slightly in how they
determine the packages to install. I'm working on fixing preupgrade to match
anaconda's behavior.
Comment 2 Will Woods 2008-09-29 14:05:47 EDT
With preupgrade-0.9.8 and anaconda-11.4.1.40 (F10 Beta), preupgrade should be downloading the correct package set. 

If preupgrade somehow *still* misses a package, anaconda should complete the upgrade anyway.
Comment 3 Fedora Update System 2008-10-02 19:04:05 EDT
preupgrade-0.9.8-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-0.9.8-2.fc9
Comment 4 Fedora Update System 2008-10-02 19:04:10 EDT
preupgrade-0.9.8-2.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/preupgrade-0.9.8-2.fc8
Comment 5 Fedora Update System 2008-10-03 18:28:42 EDT
preupgrade-0.9.8-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 6 Fedora Update System 2008-10-03 18:32:04 EDT
preupgrade-0.9.8-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 7 Fedora Update System 2008-10-23 12:36:51 EDT
preupgrade-0.9.8-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 8 Fedora Update System 2008-10-23 12:40:10 EDT
preupgrade-0.9.8-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 9 Fedora Update System 2008-11-11 21:58:28 EST
preupgrade-0.9.9-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8576
Comment 10 Fedora Update System 2008-11-11 21:59:27 EST
preupgrade-0.9.9-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8545
Comment 11 Fedora Update System 2008-11-21 18:49:08 EST
preupgrade-1.0.0-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.0-1.fc10
Comment 12 Fedora Update System 2008-11-26 01:12:22 EST
preupgrade-1.0.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2008-11-26 01:13:38 EST
preupgrade-1.0.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-11-26 01:22:07 EST
preupgrade-1.0.0-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.