Bug 446826

Summary: preupgrade misses a leading '/' in the root kernel parameter
Product: [Fedora] Fedora Reporter: Shailesh Narvekar <slashn>
Component: preupgradeAssignee: Will Woods <wwoods>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: dale, davidf, fedoration, luis, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://shailesh-techtravels.blogspot.com/2008/05/sulphurised-fedora-9-preupgrade.html
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-01 10:43:56 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Shailesh Narvekar 2008-05-16 06:42:38 EDT
Description of problem:
preupgrade on completion of first step creates an entry in the boot menu. The
kernel parameters passed here include something like
hd:sda4:boot/upgrade/stage2.img. When this menu option was selected stage2
refused to load as it could not locate stage2.img. A helpful screen appeared
with which to locate drive and path, but option entered here didnt work as well.

Added a leading '/' ie hd:sda4:/boot/upgrade and it worked.


Version-Release number of selected component (if applicable):
preupgrade-0.9.3-3.fc8

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Luis Villa 2008-05-16 07:38:13 EDT
Yeah, I saw this too. 

The bug isn't low/low; it makes the system inoperable unless you know enough to
spot the missing /.
Comment 2 Seth Vidal 2008-05-16 08:02:58 EDT
It's only inoperable only for one reboot.

The installer kernel is only the default kernel for the next reboot, not forever.

Also this problem has been fixed in the upstream bzr - just not released as a
package, yet.

Comment 3 Will Woods 2008-05-19 17:29:33 EDT
Yes, this is fixed in bzr - see trac ticket #19:
https://fedorahosted.org/preupgrade/ticket/19

This bug will be updated when we push out a new preupgrade package.
Comment 4 Dale Bewley 2008-10-30 17:13:33 EDT
I just tried preupgrade from F8 to F9, and I have /boot on root. Apparently this patch from May '08 has still not been released. I'll try the workaround, but can a new pkg be spun, please?
Comment 5 Will Woods 2008-10-30 21:19:39 EDT
It's in the updates-testing repo - preupgrade-0.9.8-2.fc[89].