Bug 447248

Summary: 'Personal File Sharing' doesn't share files with others on the LAN
Product: [Fedora] Fedora Reporter: Bruce Brackbill <brackbillbruce>
Component: gnome-user-shareAssignee: Bastien Nocera <bnocera>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: bnocera
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-19 06:07:45 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Bruce Brackbill 2008-05-19 00:37:31 EDT
Description of problem:
'Personal File Sharing' doesn't share files with others on the LAN.

Version-Release number of selected component (if applicable):
gnome-user-share-0.31-1.fc9.i386
avahi-0.6.22-10.fc9.i386

How reproducible:
Choose System-> Preferences -> Internet and Network -> "Share Public Files On
Network" on the machine (~/Public) I want to share.

Actual results:
No Shares Under Places -> Network on the OTHER machines on the LAN.

Expected results:
See shared folder on the other machines on the LAN.

Additional info:

Things appear to be running fine ( Avahi, Apache ) and I've opened up UDP Port
5353 on both the serving machine ( Server ) and receiving machine ( Client ) . 
With 5353 open, the Server can see the Share ( Places-> Network ), but the
Client cannot.

I can do a "connect to server" on the Client and manually enter the IP and the
"random Apache port" of the Server, but this kind of defeats the whole "one
click/ share" that "Share Public Files On Network" is aiming for.

These bugs look relevant:
https://bugzilla.redhat.com/show_bug.cgi?id=446828
https://bugzilla.redhat.com/show_bug.cgi?id=444427

... but it is still not working for me even when I open Port 5353.

The client is a wireless laptop running b43-pci-bridge.
Comment 1 Bruce Brackbill 2008-05-19 03:04:08 EDT
OK, I'm a little further along.  It looks like I had opened Port 5353 "TCP" and
not UDP on the client. Now that I've opened up UDP 5353 on the client, Nautilus
now sees "Bruce's Public files on localhost.localdomain" under Network".

But if I click on it I get:

"Unable to mount location
HTTP Error: Cannot connect to destination"

I'v tried "Share Public Files On Network" with and without passwords.

The username on the Client and Server machines are both Bruce if that matters.
Comment 2 Bastien Nocera 2008-05-19 06:07:45 EDT
Try disabling the firewalls on both side. Also, it's likely that you can't
connect to the HTTP server as its port is blocked as well.

*** This bug has been marked as a duplicate of 179187 ***