This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 448097

Summary: RHEL 5.2 doesn't start in kvm virtual machine
Product: [Fedora] Fedora Reporter: Matěj Cepl <mcepl>
Component: kvmAssignee: Glauber Costa <gcosta>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: berrange, clalance, katzj, k.georgiou, thoger, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-24 01:11:39 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
/proc/cpuinfo
none
/etc/libvirt/qemu/tikanga.xml
none
output of dmidecode
none
sysreport
none
Introductory grub screen to show which kernel versions I have
none
editing kernel command line
none
kernel panicking
none
screenshot of non-reproduction none

Description Matěj Cepl 2008-05-23 09:44:05 EDT
Description of problem:
When booting RHEL 5.1 (just hoped to upgrade) in kvm virtual machine (it used to
work like a month ago when I started the machine last time; then it was still
Fedora Rawhide), the boot doesn't get over "Enabling local filesystem quotas".
Then it freezes and doesn't do anything else (waited half an hour to be sure).
Unfortunately, because the computer didn't start up, I don't know much how to
get more information about the issue.

Version-Release number of selected component (if applicable):
libvirt-0.4.2-3.fc9.i386
PolicyKit-0.8-2.fc9.i386
selinux-policy-targeted-3.3.1-55.fc9.noarch
kernel-2.6.25.4-26.fc9.i686
qemu-0.9.1-5.fc9.i386
qemu-img-0.9.1-5.fc9.i386
kvm-65-4.fc9.i386

How reproducible:
100% in two tries

Steps to Reproduce:
1.(as root) virsh create /etc/libvirt/qemu/tikanga.xml ; virt-viewer -c
qemu:///system tikanga
2.
3.
  
Actual results:
freezes on "Enabling local filesystem quotas"

Expected results:
it should work, and Firefox shouldn't break (which is I wanted to test at the
first place)
Comment 1 Glauber Costa 2008-05-23 10:51:59 EDT
Hi,

Posting the configuration file (tikanga.xml) would really help for us to spot a
bit better what kind of things are happening there.
Also, as a startup, please post host information (cpuinfo to start with)

meanwhile, I'll see if I can reproduce the problem
Comment 2 Chris Lalancette 2008-05-23 12:16:47 EDT
Note that 5.2 under KVM is known to be broken as well.  That is a combination of
two bugs; one a bug in the powernow driver in 5.2 (which should be fixed in
5.3), the second being the fact that KVM doesn't export DMI information.  Both
should really be fixed (the latter upstream).

Chris Lalancette
Comment 3 Matěj Cepl 2008-05-23 12:39:07 EDT
Created attachment 306518 [details]
/proc/cpuinfo
Comment 4 Matěj Cepl 2008-05-23 12:39:42 EDT
Created attachment 306519 [details]
/etc/libvirt/qemu/tikanga.xml
Comment 5 Matěj Cepl 2008-05-23 12:41:42 EDT
Created attachment 306520 [details]
output of dmidecode
Comment 6 Matěj Cepl 2008-05-23 14:05:57 EDT
Created attachment 306530 [details]
sysreport

OK, to make sure that the information is complete, here is sysreport attached.
Comment 7 Tomas Hoger 2008-06-13 07:54:18 EDT
(In reply to comment #2)
> Note that 5.2 under KVM is known to be broken as well.  That is a combination of
> two bugs; one a bug in the powernow driver in 5.2 (which should be fixed in
> 5.3), the second being the fact that KVM doesn't export DMI information.  Both
> should really be fixed (the latter upstream).

Are there any workarounds for these issues?
Comment 8 Chris Lalancette 2008-06-13 08:57:56 EDT
Not that I know of; the code with the problem int 5.2 is in the bootpath, and I
don't know of a way to disable that bootpath.  And adding the DMI information to
KVM is something that should be done, but is not entirely trivial.  You should
stick with a 5.1 kernel for now, if you can get it working.

Chris Lalancette
Comment 9 Matěj Cepl 2008-06-13 11:54:40 EDT
Which means reinstall over slow ADSL line. Oh well.
Comment 10 Tomas Hoger 2008-06-13 12:11:03 EDT
Matej, 5.1 does not work with F9 KVM?  5.2 with 5.1 kernel seems to work fine on
F8 KVM.
Comment 11 Matěj Cepl 2008-06-13 12:14:29 EDT
I have apparently upgraded to 5.2 kernel or 5.1 doesn't work with F9. I don't
know, and I cannot test it because I cannot get to the virtual machine to find
out ;-)).
Comment 12 Matěj Cepl 2008-06-14 03:35:30 EDT
Created attachment 309327 [details]
Introductory grub screen to show which kernel versions I have

I found that the only way how to collect some information about this issue is
to run whole thing in virt-manager (which I don't usually use) and make a lot
of screenshots. So this is the first image my funnies about whole story. This
is to show which kernels I have installed in the virtual machine and that I
have selected the older one.
Comment 13 Matěj Cepl 2008-06-14 03:36:34 EDT
Created attachment 309328 [details]
editing kernel command line

I have removed "quiet rhgb" from the kernel command line
Comment 14 Matěj Cepl 2008-06-14 03:46:27 EDT
Created attachment 309329 [details]
kernel panicking

voilá! this is the conclusion -- kernel panick when local drivers are mounted
Comment 15 Chris Lalancette 2008-06-16 02:52:26 EDT
Yes, and in regards to comment #10, 5.1 KVM guests work just fine for me here on
both AMD and Intel.  Although I have to admit, I'm just using 53.el5, not one of
the releases after that.  Matej, can you install the .53 (not 53.1.6), and see
if that boots?

Chris Lalancette
Comment 16 Matěj Cepl 2008-06-16 04:48:00 EDT
(In reply to comment #15)
> Yes, and in regards to comment #10, 5.1 KVM guests work just fine for me here
> on both AMD and Intel.  Although I have to admit, I'm just using 53.el5, not 
> one of the releases after that.  Matej, can you install the .53 (not 53.1.6),
> and see if that boots?

Well, I have to reinstall the guest from scratch, which will take some time --
this is not my highest priority at the moment.
Comment 17 Matěj Cepl 2008-06-17 06:26:58 EDT
OK, I have reinstalled and bare RHEL 5.1GA works perfectly. Running yum upgrade
and will report the results.
Comment 18 Matěj Cepl 2008-06-17 14:08:03 EDT
Created attachment 309649 [details]
screenshot of non-reproduction

With upgrading to the latest version of everything (including kernel
2.6.18-92.1.1.el5) everything works without a problem. I would hesitate to just
close this bug, if there is not a good explanation why it suddenly works.
Comment 19 Tomas Hoger 2008-06-17 14:15:32 EDT
Matej, still running on the Intel host?
Comment 20 Matěj Cepl 2008-06-17 14:42:27 EDT
Host system is still the same (Fedora 9, kernel-2.6.25.6-55.fc9.i686,
kvm-65-7.fc9.i386).
Comment 21 Matěj Cepl 2009-04-24 01:11:39 EDT
I has been working for some time already.