Bug 4481

Summary: when accessing a rh6.0 machine from behind a firewall disconnect after a maximum of 30 minutes idle
Product: [Retired] Red Hat Linux Reporter: torbin
Component: telnetAssignee: Florian La Roche <laroche>
Status: CLOSED NOTABUG QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-05 02:38:41 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description torbin 1999-08-11 15:16:56 EDT
Recently upgraded a server from Redhat 5.2 to Redhat 6.0.
The server is in front of the local firewall machine and
when telnetting from behind the firewall will be
disconnected from the server after a maximum of 30 minutes
of being idle. If accessed from an outside source telnet is
not disconnected even after hours of being idle, also a
Redhat 5.2 machine that has not been upgraded does not
disconnect the telnet sessions from behind the firewall.
Comment 1 Preston Brown 1999-08-23 11:28:59 EDT
are you using tcsh or bash as your shell?
Comment 2 torbin 1999-09-05 02:38:59 EDT
we use bash as the default shell
Comment 3 Pekka Savola 2000-07-16 16:35:15 EDT
This is almost certainly a problem in your firewall.  For example, Linux
Firewalls disconnect idle TCP connections after certain period of time unless
keepalive messages are sent.

If the firewall in question is Linux, you might want to check out 'ipchains -M'.

Also, you could try to downgrade your 6.0 -system's telnet RPM to one from 5.2,
to see if you can isolate the problem.