Bug 448179

Summary: LyX segfault on load
Product: [Fedora] Fedora Reporter: Ben Boeckel <fedora>
Component: lyxAssignee: Rex Dieter <rdieter>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 9CC: jamatos
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 1.5.5-1.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-05-31 02:11:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ben Boeckel 2008-05-24 05:03:44 UTC
Description of problem:
LyX doesn't start with Qt-4.4.0. A window flashes and then LyX outputs
information to the terminal (output below).

Version-Release number of selected component (if applicable):
$ rpm -q lyx qt
lyx-1.5.4-1.fc9.x86_64
qt-4.4.0-4.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Start LyX (qith Qt-4.4.0)
2. LyX crashes
  
Additional info:
$ lyx
QPaintEngine::setSystemClip: Should not be changed while engine is active
QPaintEngine::setSystemClip: Should not be changed while engine is active
QWidgetPrivate::beginSharedPainter: Painter is already active

lyx: SIGSEGV signal caught
Sorry, you have found a bug in LyX. Please read the bug-reporting instructions
in Help->Introduction and send us a bug report, if necessary. Thanks !
Bye.
Aborted

Comment 1 José Matos 2008-05-24 07:16:43 UTC
Where does qt-4.4.0-4.fc9.x86_64 comes from? I don't see it on koji.

On the other hand what I see on koji is lyx-1.5.5.

lyx-1.5.4 was released before qt-4.4.0, lyx-1.5.5 was released after and it
fixes the compatibility problems with qt-4.4.


Comment 2 Ben Boeckel 2008-05-24 14:27:12 UTC
Rex had built qt-4.4.0 and I got it from him. Using it with qt-4.3.4 does not
crash (reported by someone else on IRC). I'll try the 1.5.5 build and report back.

Comment 3 Rex Dieter 2008-05-24 15:22:50 UTC
Right, so this isn't strictly anyone with stock fedora would see atm, but...
I've build lyx-1.5.5, I just hadn't gotten round-tuit at issueing an update.

JosÃ, can you issue the update?  (Else, I'll get it it eventually).

Comment 4 José Matos 2008-05-29 15:48:05 UTC
I have been both swamped by work and today I was bitten by this problem so I
have issued an update for F[7-9].:-)
I requested a push to the updates since the reactions to this release have been
very good.

Comment 5 Rex Dieter 2008-05-29 16:31:20 UTC
make sure to reference this bug in the update request.

Comment 6 José Matos 2008-05-29 16:45:56 UTC
Done.

Comment 7 Rex Dieter 2008-05-29 16:55:19 UTC
thx, but straight to stable, bypassing updates-testing, are you that brave? :)

Comment 8 José Matos 2008-05-29 17:07:10 UTC
I had feedback from users of F9 issuing a +1 for this release.

Using thus this "+3 karma" rule I have bypassed testing. :-)

Comment 9 Rex Dieter 2008-05-29 19:13:49 UTC
excellent!

Comment 10 Fedora Update System 2008-05-31 02:11:37 UTC
lyx-1.5.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2008-05-31 02:15:57 UTC
lyx-1.5.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2008-05-31 02:17:16 UTC
lyx-1.5.5-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2008-07-26 06:10:39 UTC
lyx-1.5.5-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.