Bug 449200

Summary: Conflicts between libxslt.x86_64 and libxslt.i386
Product: [Fedora] Fedora Reporter: Harald <harald.berghoff>
Component: libxsltAssignee: Daniel Veillard <veillard>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: triage
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-30 17:06:59 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Harald 2008-05-31 06:45:25 UTC
+++ This bug was initially created as a clone of Bug #313001 +++
+++ This bug was initially created as a clone of Bug #312991 +++

Description of problem:
On Fedora 9/x86-64, when libxslt causes conflicts. Any automated update fails
for this reason.


Version-Release number of selected component (if applicable):
libxslt-1.1.23-3.fc9.i386
libxslt-1.1.24-1.fc9.x86_64


How reproducible:
Every time.

Steps to Reproduce:
1. Install Fedora 9/x86-64
2. Have libxslt-1.1.23-3.fc9.i386 and libxslt-1.1.23-3.fc9.x86_64 installed
3. yum update libxslt
  
Actual results:
Transaction Check Error:
  file /usr/bin/xslt-config from install of libxslt-devel-1.1.21-1.fc7 
conflicts with file from package libxslt-devel-1.1.21-1.fc7

  file /usr/share/man/man1/xsltproc.1.gz from install of
libxslt-1.1.24-1.fc9.i386 conflicts with file from package
libxslt-1.1.23-3.fc9.x86_64

Expected results:
The package should install without conflicts between 64 and 32 bit versions.

Additional info:
I already tried to remove the i386 Package, but i get several dependent package
which i don't wnat to remove.

Comment 1 Harald 2008-05-31 08:54:21 UTC
Just corrected the summary

Comment 2 Harald 2008-11-30 17:06:59 UTC
Though this bug was not worked on, i solved the issue in really removing the i386 packages and installed the x64 Packages.

Anyway after doing some research this might as well solved by running
yum-complete-transaction until no open transaction is left.