Bug 449209

Summary: claws-mail wrongly BR libgnomeprintui22-devel
Product: [Fedora] Fedora Reporter: Tuomo Soini <tis>
Component: claws-mailAssignee: Andreas Bierfert <andreas.bierfert>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideKeywords: Reopened
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 3.5.0-1.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-18 23:08:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tuomo Soini 2008-05-31 11:20:12 UTC
Description of problem:

wrong BR: libgnomeprintui22-devel

Version-Release number of selected component (if applicable):

claws-mail-3.4.0-1

How reproducible:

Always.

Additional info:

When gtk2 is version 2.10+ claws-mail will not use gnomeprint. Bu changing gkt2
version requirement to gtk2 >= 2.10.0 libgnomeprintui22 which is currently
unused can be dropped as build requirement. This can be easily checked from
buildlog, claws-mail is currently not using gnomeprint.

Comment 1 Fedora Update System 2008-06-18 04:49:25 UTC
claws-mail-3.4.0-2.fc9 has been submitted as an update for Fedora 9

Comment 2 Fedora Update System 2008-06-18 04:52:11 UTC
claws-mail-3.4.0-2.fc8 has been submitted as an update for Fedora 8

Comment 3 Fedora Update System 2008-06-20 19:07:48 UTC
claws-mail-3.4.0-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update claws-mail'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5483

Comment 4 Fedora Update System 2008-06-27 19:35:03 UTC
claws-mail-3.4.0-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2008-06-27 19:37:04 UTC
claws-mail-3.4.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Tuomo Soini 2008-06-27 19:53:16 UTC
Only part of this bug was fixed. Now libgnomeprintui22-devel BR is removed but
gtk2-devel version requirement is now wrong. If package is now tried to build on
system with older than 2.10.0 gtk2-devel build still requires
libgnomeprintui22-devel.

-BuildRequires: gtk2-devel >= 2.6.2
+BuildRequires: gtk2-devel >= 2.10.0


Comment 7 Jens Petersen 2008-06-30 02:37:20 UTC
Actually BR libgnomeprintui22-devel still seems to be there?

Comment 8 Tuomo Soini 2008-06-30 06:06:53 UTC
On rawhide, yes. it's removed on f8 and f9. That's why I didn't check changes
earlier because I only follow rawhide.

Rawhide doesn't have partly fixed version yet.

Comment 9 Fedora Update System 2008-07-06 20:40:39 UTC
claws-mail-3.5.0-1.fc8 has been submitted as an update for Fedora 8

Comment 10 Fedora Update System 2008-07-06 20:58:09 UTC
claws-mail-3.5.0-1.fc9 has been submitted as an update for Fedora 9

Comment 11 Fedora Update System 2008-07-09 02:53:30 UTC
claws-mail-plugins-3.5.0-1.fc9, claws-mail-3.5.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update claws-mail-plugins claws-mail'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6246

Comment 12 Fedora Update System 2008-07-18 23:08:08 UTC
claws-mail-plugins-3.5.0-1.fc9, claws-mail-3.5.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2008-07-23 07:19:48 UTC
claws-mail-plugins-3.5.0-1.fc8, claws-mail-3.5.0-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.